Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Raoni Jardim

Contagem de células no excel

Recommended Posts

Tenho uma planilha que, a primeira coluna contém um numero de registro. Essa coluna pode estar em branco, com 4 algarismos ou com 6 algarismos.. ex: 

           A 
1      451298 
2      875490 
3  
4        7849 
5      875466 
6      451190 
7        4497 
8      751487 
... 

Em uma outra célula, preciso contar quantos registros dessa coluna tem o QUINTO ALGARISMO = 9 (ou seja, nesse exemplo seriam 3) 

estava usando a fórmula =CONT.SE(A1:A8;"????9?"), mas não está funcionando. 

o que devo fazer?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Raoni Jardim olhei diversas vezes para seu exemplo... o resultado deveria ser 4 e não 3, certo ?  :)

 

Resolvi com a seguinte fórmula...

 

=SOMA((ESQUERDA(DIREITA(A1:A8;2);1)="9")*1)

 

No entanto, trata-se de uma fórmula matricial, ou seja, depois de digitá-la você não digita ENTER, mas sim SHIFT-CTRL-ENTER !  ;)

 

A fórmula separa o dígito DECIMAL do intervalo (a parte esquerda/direita) e verifica se é o 9...

 

Depois executa uma soma da multiplicação por 1, ou seja, imagine a execução linha a linha...

 

Na linha 1, por exemplo, ocorre o MATCH (o DECIMAL é o 9!). Pela fórmula "X=9" sendo um SIM dá um UM (binário) e multiplicando-o por 1 dá 1...

 

Nas linhas 3 ou 4, não ocorre o MATCH (não é 9). Pela fórmula "X=9" dá um NÃO ou ZERO (binário) e multiplicando-o por 1 dá zero...

 

No final de todas as linhas, somam-se os resultados! Na sequencia do exemplo seriam:

 

1+1+0+0+0+1+1+0 = 4 !!

 

:D

 

OBS - Fica legal editar a fórmula (F2) e vizualizar... 

Editado por Mlramos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×