Ir ao conteúdo
  • Cadastre-se
Raoni Jardim

Contagem de células no excel

Recommended Posts

Tenho uma planilha que, a primeira coluna contém um numero de registro. Essa coluna pode estar em branco, com 4 algarismos ou com 6 algarismos.. ex: 

           A 
1      451298 
2      875490 
3  
4        7849 
5      875466 
6      451190 
7        4497 
8      751487 
... 

Em uma outra célula, preciso contar quantos registros dessa coluna tem o QUINTO ALGARISMO = 9 (ou seja, nesse exemplo seriam 3) 

estava usando a fórmula =CONT.SE(A1:A8;"????9?"), mas não está funcionando. 

o que devo fazer?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Raoni Jardim olhei diversas vezes para seu exemplo... o resultado deveria ser 4 e não 3, certo ?  :)

 

Resolvi com a seguinte fórmula...

 

=SOMA((ESQUERDA(DIREITA(A1:A8;2);1)="9")*1)

 

No entanto, trata-se de uma fórmula matricial, ou seja, depois de digitá-la você não digita ENTER, mas sim SHIFT-CTRL-ENTER !  ;)

 

A fórmula separa o dígito DECIMAL do intervalo (a parte esquerda/direita) e verifica se é o 9...

 

Depois executa uma soma da multiplicação por 1, ou seja, imagine a execução linha a linha...

 

Na linha 1, por exemplo, ocorre o MATCH (o DECIMAL é o 9!). Pela fórmula "X=9" sendo um SIM dá um UM (binário) e multiplicando-o por 1 dá 1...

 

Nas linhas 3 ou 4, não ocorre o MATCH (não é 9). Pela fórmula "X=9" dá um NÃO ou ZERO (binário) e multiplicando-o por 1 dá zero...

 

No final de todas as linhas, somam-se os resultados! Na sequencia do exemplo seriam:

 

1+1+0+0+0+1+1+0 = 4 !!

 

:D

 

OBS - Fica legal editar a fórmula (F2) e vizualizar... 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×