Ir ao conteúdo
  • Cadastre-se
Luan Martins

Problema na estrutura "escolha"

Recommended Posts

Estou fazendo a seguinte questão,

 

1.      A  concessionária  de  veículos  “CARANGO  VELHO”  está  vendendo  os  seus  veículos  com  desconto.  Faça  um algoritmo que calcule e exiba o valor do desconto e  o valor a ser pago pelo  cliente de vários carros. O desconto deverá ser calculado de acordo com o ano do veículo. Até 2000  -  12% e acima de 2000  -  7%. O sistema deverá perguntar se deseja continuar calculando desconto até que a resposta seja: “(N) Não” . Informar total de carros com ano até 2000 e total geral.

 

ai da o seguinte erro, no final pede pra mostrar quantos carros de menor que 2000 foram pesquisados e quantos maiores de 2000 foram pesquisados, e da sempre o mesmo numero, se eu pesquisar 1carro 2000

vai da 

1 <= 2000

1 > 2000

     

 

aqui em baixo o codigo que deu erro

 

algoritmo "Carango_velhor"// Função :// Autor :// Data : 03/06/2014// Seção de Declarações var   ano, cont, quant_car : inteiro   valor ,Desc ,total ,t ,desconto ,val_fin ,calculo ,S,N : realinicio// Seção de Comandos   escreval ("Informe a quantidade de carro quer pesquisar")   leia (quant_car)   para cont de 1 ate quant_car passo 1 faca        escreval ("Informe o ano do veiculo")        leia (ano)        escreval("Informe o valor do veiculo")        leia (valor)        se ano <= 2000 então           Desc <- 12/100           total <- total + 1           t <- t + 1           senao                desc <- 5/100                total <- total + 1                t <- t + 1        fimse  desconto <- desc * valor  val_fin <- valor - desconto  escreval (" O valor do carro com o desconto é: ", val_fin)  escreval (" Foram calculados ", t , " carros com ano até 2000")  escreval (" Foram calculados ", t , " carros com ano a cima de 2000")  escreval ("O total final foi ", total)  fimpara  fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites


Claro que maior que 2000 e menor que 2000 vai dar o mesmo valor. Se você colocou uma variável para receber esse valor.

Dessa forma um valor vai sobre por o outro, ou seja já que você colocou t no se, no senão  você colocaria outra letra.

Segue o trecho do código que possui o erro 

se ano <= 2000 então           Desc <- 12/100           total <- total + 1           t <- t + 1           senao                desc <- 5/100                total <- total + 1                t <- t + 1

Caso o problema persista entre em contato novamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×