Ir ao conteúdo
  • Cadastre-se
Luan Martins

Ajuda U rgente estrutura condicional

Recommended Posts

Pessoal tenho que entregar o trabalho para amanha e nao consigo fazer a seguinte questão

 

1.      Faça um algoritmo que leia o nome, o sexo, a altura e a idade de uma pessoa. Calcule e mostre nome e o seu peso ideal de acordo com as seguintes características da pessoa:

 

 

aaa.png?1401851763

 

 

o codigo ficou assim, so que tem um problema, eu nao consigo por ele

 

pra se for homem ir até tal estrutura, 

 

 

se for mulher pular tudo e ir pra estrutura reservada para mulher

 

((((((((((((( O codigo nao ta terminado, porém esse codigo pronto tem que ler somente se a resposta no sexo foir H de Homem, e eu nao to sabendo fazer isso, alguem sabe como faço?????? ))))))))))))))))))))

 

 

algoritmo "semnome"// Função :// Autor :// Data : 03/06/2014// Seção de Declarações var   nome, sexo, H, M : caracter   peso, altura, peso_ideal : real   idade : inteiroinicio// Seção de Comandos    escreval ("Informe o seu nome")   leia (nome)   escreval ("")   escreval ("Informe o seu sexo ( H - Homem ) ( M - Mulher )")   leia (sexo)   escreval ("")   escreval ("Informe a sua idade")   leia (idade)   escreval ("")   escreval ("Informe a sua altura")   leia (altura)   escreval ("")   escolha (sexo)           caso H            se (altura > 1.70) e (idade <= 20) então               peso_ideal <- (72.7 * altura) - 58               escreval ("")               escreval ("Senhor(a) ",nome," o seu peso ideal é de: ",peso_ideal)               senao                    se ( altura > 1.70 ) e ( idade >= 21 ) e ( idade <= 39 ) então                       peso_ideal <-  (72.7 * altura) - 53                       escreval ("")                       escreval ("Senhor(a) ",nome," o seu peso ideal é de: ",peso_ideal)                       senao                            se ( altura > 1.70 ) e ( idade >= 40 ) então                               peso_ideal <-  (72.7 * altura) - 45                               escreval ("")                               escreval ("Senhor(a) ",nome," o seu peso ideal é de: ",peso_ideal)                               senao                                    se (altura <= 1.70 ) e ( idade <= 40 ) então                                       peso_ideal <-  (72.7 * altura) - 50                                       escreval ("")                                       escreval ("Senhor(a) ",nome," o seu peso ideal é de: ",peso_ideal)                                       senao                                            se ( altura <= 1.70 ) e ( idade > 40 ) então                                               peso_ideal <-  (72.7 * altura) - 58                                               escreval ("")                                               escreval ("Senhor(a) ",nome," o seu peso ideal é de: ",peso_ideal)                                            fimse                                    fimse                            fimse                    fimse            fimse   fimescolha                                                 fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

No trecho:

caso H    se (altura > 1.70) e (idade <= 20) então        peso_ideal <- (72.7 * altura) - 58        escreval ("")

ao invés de você fazer da forma acima, faça como está aqui abaixo:
 

caso "H"    se (altura > 1.70) e (idade <= 20) então        peso_ideal <- (72.7 * altura) - 58        escreval ("")

Sei que o símbolo do "~" é colocado automaticamente, mas caso você queira copiar o seu próprio tag code do Clube do Hardware para o Visualg, se atente ao senão, tire a acentuação quando coloca-lo no programa(visualg).

 

 

 

 

Obs: Bons estudos e persista, pois você é capaz.      

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×