Ir ao conteúdo
  • Cadastre-se
paulo tadeu pereira

RESOLVIDO Ocultar conteudo da celula se valor for igual a outra

Recommended Posts

Boa tarde 

 

Estou fazendo uma planilha de roteireizaçao aqui para a empresa mas estou com um problema: 

 

Para fazer a roteirizaçao a região das entregas foi dividida em pequenas rotas mas alguns cidades pertencem a mais de uma rota.

Ex: Araranguá esta na rota 01 e também na rota 02 então criei uma relação com o código das rotas e cidades. 

 

Na planilha e feito o roteiro de entregas então o que eu quero fazer é digitar o código da rota em uma célula e ela trazer as cidades dessa rota nas células ao lado

EX: na celula D3 eu digito o código da rota e nas células E3:e8 retorna as cidades dessa rota

      na celula D4 eu digito o codigo da próxima rota e nas células F4:F8 retorna as cidades dessa rota

 

Agora o Problema:

se a Cidade já apareceu entre E3:E8 e também esta na próxima rota para aparecer entre F4:F8 eu quero que na segunda vez que ela for retornar a informação seja ocultada. 

 

em anexo esta um print, se alguem tiver uma ideia de como fazer

 

.post-733454-0-56037900-1407869130_thumb.

 

 


Para esse exemplo que postei eu queria que a informaçao de F5 estivesse oculta.

 

A formula que usei para preenchimento é essa =SEERRO(ÍNDICE($X$4:$Y$61;MENOR(SE($X$4:$X$61=$D$4;LIN($X$4:$X$61)-3);LIN(D1));2);"") 

Compartilhar este post


Link para o post
Compartilhar em outros sites

da pra fazer por formula, mas to achando complicado pois é preciso definir a regiao que a cidade ja pode ter aparecido e no seu caso parece que vai preenchendo as colunas uma por uma, de E até onde for, é isso? Ideal era que as cidades fosse aparecendo em aopenas uma coluna

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente a seguinte fórmula na região de E3 até a última linha da coluina H:

=SE(CONT.SE($E$3:E3;C3)>=1;"";C3)

Substitua a referência C3 pela sua fómula que puxa a cidade.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×