Ir ao conteúdo
  • Cadastre-se
leo_michilotti

[EXCEL] Fómula Excel com Erro

Recommended Posts

Td bem pessoal?

 

Tenho uma planilha de tarefas onde a coluna B possui tarefas diversas e repetidas, na coluna A tenho 4 tipos de status referentes a essas tarefas, Completed, Aborted, Completed/Failures! e Failures, e em uma outra coluna E eu tenho a lista com cada tarefa singular, então eu preciso que cada item da E faça uma varredura na lista B de tarefas encontrando itens semelhantes e então verifique na coluna A o status dessas tarefas e apresente qual o status da maioria, se a TAREFA A possuir 2 itens com Failures, 1 Aborted e 5 Completed, então a TAREFA A recebe o valor Successfuly.

 

Com a grande ajuda do Xflapc2 eu consegui entender como poderia fazer isso com 2 status, mas agora eu preciso que tenha 4 status e a formula que montei é essa:

 

=SE(CONT.SES($BI$2:$BI$700;BN2;$BA$2:$BA$700;"Completed")<CONT.SES($BI$2:$BI$700;BN2;$BA$2:$BA$700;"Failure");"Failure!");SE(E(CONT.SES($BI$2:$BI$700;BN2;$BA$2:$BA$700;"Completed")<CONT.SES($BI$2:$BI$700;BN2;$BA$2:$BA$700;"Aborted");"Aborted!");SE(E(CONT.SES($BI$2:$BI$700;BN2;$BA$2:$BA$700;"Completed")<CONT.SES($BI$2:$BI$700;BN2;$BA$2:$BA$700;"Completed/Failures!");"Completed/Failures!");"Successfully"))

 

porém ela esta dando erro de Valor!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá. Ela receberá valor sucesso quando a maioria for completed e falha se nao? Ou haverá outros estados intermediários!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá. Ela receberá valor sucesso quando a maioria for completed e falha se nao? Ou haverá outros estados intermediários!

 

Sim sim, havera outras estado, é isso que ta me dando um nó

 

Se a maioria for Completed = Successfuly

Se a maioria Failure = Failure

Se a maioria Completed/Failures! = Completed/Failures!

Se a maioria Aborted = Aborted

E se a metade for qualquer outro estado e a outra metade for Completed, ele receberá Successfully tb

 

 

valeu  Xflapc2!!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×