Ir ao conteúdo
  • Cadastre-se
Ronimar

Dúvida em Exercicios Visualg

Recommended Posts

Ola pessoa estou com duvida no seguinte exercicios
 
1--Faça um programa de calculadora simples com as seguintes operações possíveis: adição, subtração, multiplicação e divisão. O programa inicia apresentando ao usuário um menu de opções como mostrado abaixo:
 
-----------------------------------------------------
Calculadora
1. Adição
2. Subtração
3. Multiplicação
4. Divisão
5. Sair do programa
-----------------------------------------------------
 
Entre com o primeiro número:
Entre com o segundo número:
Entre com sua opção (1 a 5):
 
Crie uma função que apresente o menu inicial acima, leia os dois números que serão operados e retorne a opção do usuário para o programa principal. Esta opção é então analisada e o programa principal chama as funções de adição, subtração, multiplicação e divisão conforme a opção do usuário. Se a opção for inválida, informe ao usuário e peça a ele para entrar com uma opção válida. Se a opção for válida, execute-a utilizando os dois números digitados mostrando o resultado. Após a execução da operação o programa volta a apresentar o menu inicial até que o usuário encerre o programa com a opção 5.
 
2--Escreva uma função que receba 2 números inteiros n1 e n2  como entrada e retorne os números e a soma de todos os números inteiros contidos no intervalo [n1,n2]. 
 
Código do 1 exercicio

algoritmo "semnome"// Função :// Autor :// Data : 30/8/2014// Seção de Declaraçõesvarn1,n2,opcao,num1,num2 : REALfuncao Fsoma(n1, n2 :REAL): REAL  var  i,soma : real         Inicio               soma <- n1 + n2               retorne soma         fimfuncao funcao Fsubtracao(n1, n2 :REAL): REAL  var  i,subtracao : real         Inicio               subtracao <- n1 - n2               retorne subtracao       FIMFUNCAOfuncao Fmultiplicacao(n1, n2 :REAL): REAL  var  i,multiplicacao : real         Inicio               multiplicacao <- n1 * n2               retorne multiplicacao         fimfuncao  funcao Fdivisao(n1, n2 :REAL): REAL  var  i,divisao : real         Inicio               divisao <- n1 / n2               retorne divisao         FIMFUNCAOinicio// Seção de Comandos                escreval("************************************** ")                escreval("Calculadora Simples Opções Disponiveis ")                escreval("************************************** ")                escreval(" 1 -->Adição")                escreval(" 2 -->Subtração")                escreval(" 3 -->Multiplicação")                escreval(" 4 -->Divisão")                escreval(" 5 -->Sair")                escreval("************************************** ")                escreval("Entre com a opção desejada  ")                leia(opcao)                escolha opcao                                caso 1                       escreval("Entre com o primeiro valor")                       leia(num1)                       escreval("Entre com o segundo valor")                       leia(num2)                       escreval("A soma será " ,Fsoma(num1,num2))                caso 2                       escreval("Entre com o primeiro valor")                       leia(num1)                       escreval("Entre com o segundo valor")                       leia(num2)                       escreval("A soma será " ,Fsubtracao(num1,num2))                 caso 3                       escreval("Entre com o primeiro valor")                       leia(num1)                       escreval("Entre com o segundo valor")                       leia(num2)                       escreval("A soma será " ,Fmultiplicacao(num1,num2))                 caso 4                       escreval("Entre com o primeiro valor")                       leia(num1)                       escreval("Entre com o segundo valor")                       leia(num2)                       escreval("A soma será " ,Fdivisao(num1,num2))                                       outrocaso                       escreval("pressione uma tecla para finalizar")fimalgoritmo

Código do 2 exercicio

algoritmo "semnome"// Função :// Autor :// Data : 30/8/2014// Seção de Declarações varn1,n2 : inteirofuncao Fsoma(n1, n2 :inteiro): inteiro  var  i,soma : inteiro           Inicio         se (n1 <= n2) então                       para i de n1 ate n2 faca                   i = n1                   soma = soma + i                            fimpara         fimse                  se (n1 > n2) então              para i de n2 ate n1 faca                    i = n2                   soma = soma + i              fimpara         fimse                  retorne soma                  fimfuncaoinicio// Seção de Comandos                 escreval("Digite um valor para N1")                leia(n1)                escreval("Digite um valor para N2")                leia(n2)                                                escreva("A soma dos valores será ",Fsoma(soma))fimalgoritmo

Onde estou errando neste ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×