Ir ao conteúdo
  • Cadastre-se
Distephanos

RESOLVIDO Função SE+E e #N/D para plotagem limpa.

Recommended Posts

Boa tarde a todos.

 

Estou com um gráfico com a seguinte função:

 

=SE(C37=""; ""; C37/290000)

 

A função descrita deixa uma DETERMINADA célula VAZIA quando a C37  estiver PREENCHIDA OU "VAZIA".

porém na área gráfica é plotado os pontos como zero, e fica estranho visualmente.

Já tentei mudar as configurações clicando na área do gráfico, selecionar dados, campo células/ocultas e vazias, e não ocoreu nada.

 

Será possível agregar um comando e a função SE acima, tipo:

 

=SE(C37=""; "" E(#N/D); C37/290000)

 

Estou ciente que a sintaxe está errada, mas se alguém puder ajudar eu agradeço.

 

 

post-287402-0-06640800-1410801353_thumb.

 

post-287402-0-22243700-1410801360_thumb.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde

 

Experimenente

 

SE(C37="";NÃO.DISP(); C37/290000)

 

[]s

 

Funcionou e estou muito grato...porém tem como tirar do campo o #n/d  que aparece?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim.

 

Selecione a coluna onde que aparece os #n/d  --> clique em formatação condicional --> Nova Regra --> Formatar apenas células que contenham --> em formatar apenas células com --> selecione Erros --> Formatar --> Fonte --> em Cor --> onde está automático escolha o primeiro quadradinho da esquerda que está em branco --> clique nele --> Dê OK.

 

Pronto agora a fonte vai ficar transparente quando tiver #n/d

 

Dê retorno.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim.

 

Selecione a coluna onde que aparece os #n/d  --> clique em formatação condicional --> Nova Regra --> Formatar apenas células que contenham --> em formatar apenas células com --> selecione Erros --> Formatar --> Fonte --> em Cor --> onde está automático escolha o primeiro quadradinho da esquerda que está em branco --> clique nele --> Dê OK.

 

Pronto agora a fonte vai ficar transparente quando tiver #n/d

 

Dê retorno.

Perfeito...o erro está la porém não aparece por conta da formatação condicional...e não plota a área do gráfico dentro da matriz que está vazia...

Muito Obrigado você é fera mesmo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×