Ir ao conteúdo
  • Cadastre-se
Sir Drawe

Bad Blocks em HD e tela azul!

Recommended Posts

Galera boa noite, antes de mais nada agradeço a todos por qualquer ajuda.

 

Meu hd esta com bad block, mas passei o hd tune e vi que era somente 1 setor, coisa pouca, utilizei o programa Partition Bad Disk para criar uma particao e esconder a parte com problema.

 

porém agora instalei alguns jogos nesse HD e agora todas as vezes que vou copiar um crack do jogo max payne 3 ele da tela azul e trava.... agora eu pergunto isso é problema que o HD gerou? ou poderia ser algum virus?

 

Valeuu galera

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite, você fez um procedimento interessante, e geralmente funcional, mas algo não deve ter corrido bem.

Primeiro, você não fez nenhum procedimento para tentar reparar este setor ? Como chkdsk ou HDDRegenerator ? Pois se não fez, faça.

Poste um print da aba HEALTH do HD Tune, para vermos a SMART do HD, e ver se ele realmente já realocou todos os bad sectors ruins, ou não.

abs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tentei fazer tudo isso que voce listou.

 

usei o comando chkdsk /f /r porém nao sei em qual disco ele passou, meu disco com problema ta de secundario.

 

O HDD regenerator tava corrigindo os erros de bad block ate certo ponto em que parou e apareceu a seguinte mensagem:

"If your Sata controller works in AHCI mode, change it to compatible IDE mode"

Tentei mudar a opcao na bios porém so tinha AHCI e RAID tentei nas duas e deram o mesmo erro.

 

hd_error.jpg

 

hd_tune_health.jpg

 

 

Valeu pela ajuda.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tentei fazer tudo isso que voce listou.

 

usei o comando chkdsk /f /r porém nao sei em qual disco ele passou, meu disco com problema ta de secundario.

 

O HDD regenerator tava corrigindo os erros de bad block ate certo ponto em que parou e apareceu a seguinte mensagem:

"If your Sata controller works in AHCI mode, change it to compatible IDE mode"

Tentei mudar a opcao na bios porém so tinha AHCI e RAID tentei nas duas e deram o mesmo erro.

 

hd_error.jpg

 

hd_tune_health.jpg

 

 

Valeu pela ajuda.

 

Beleza, o HD foi para o saco mesmo, porém, podemos prosseguir com a tua primeira ideia, de "isolar" a parte danificada e usar o resto, mas lembre-se que este HD nunca mais será confiável.

O teu erro foi realizar um quick scan, você deve realizar um scan completo (lento) para mapear corretamente os setores danificados, o quick é muito genérico. 

Mas antes do procedimento, execute um chkdsk /r  para que o Windows tente reparar alguma coisa, pode até rodar o HDDRegenerator para tentar tirar proveito máximo dessas ferramentas, mas como o status de setores realocados já estão em Failed, é possível que nada resolva.

 

abs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse procedimento do chkdsk /r vai verificar meus dois discos? porque o primario que uso o windows é um ssd...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse procedimento do chkdsk /r vai verificar meus dois discos? porque o primario que uso o windows é um ssd...

 

Não, mas se você tem mais de um disco, especifique a partição relativa ao teu HD danificado.

chkdsk C: /r  

 

ou D: , ou E: ou... (...)

 

 

Obs: este processo é bem demorado (depende da quantidade de dados contidos), mas não impede a utilização do computador.

abs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Como não conheço esse programa que você citou, imagino que se tu passou um Quick Scan no HD tune, então tu ainda realmente não sabe qual é toda tua "parte defeituosa", sendo necessário um full scan. 

 

abs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Passei um scan full outro dia, e apareceu  o mesmo setor com defeito, usei o scan do HDDregenerator tambem que confirmou a regiao defeituosa, so passei um quick pra ilustrar o setor com defeito....

Compartilhar este post


Link para o post
Compartilhar em outros sites

Chico, passei o CHKDSK nas 3 partiçoes e acusou e corrigiu 2 arquivos com bad blocks no disco em que tive o problema da tela azul.

 

Tem mais algum teste pra ver se o problema foi corrigido? passando o HD Tune o hd deveria ficar sem os setores em vermelho?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Desculpe a demora para responder, a principio não, mas como você fez o cálculo para criar uma partição na parte danificada do HD? Pois ali você tem o valor de cada bloco, e o HD tune te dá uma matriz de linhas e colunas, logo pela minha conta que é: 244 Mb x 50 (colunas) x 6 linhas = 73gb. Teu bad block irrecuperável está mais ou menos pelos 70 gb. Te recomendo criar uma partição (em formatação rápida) de uns 80 gb, ovbiamente não alocá-la, e usar o resto.

abs.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Foi o programa que criou as partiçoes automaticamente, percebi que ele tambem ja escondeu aproximadamente uns 9gb de setores defeituosos...

 

Por enquanto nao tive mais problemas, se tiver mais algo que possa ajudar e queira compartilhar fique a vontade, valeuu a ajuda.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×