Ir ao conteúdo
  • Cadastre-se
Alexandre Tomé Ferreira

Usar endereço relativo em apontamento de Fórmula do Excel

Recommended Posts

Bom dia amigos,

Venho quebrando a cabeça há dias para resolver a seguinte fórmula: SE($L$1<>"";PROCV($L$1;'Z:\[iDTR.xlsx]IDTR'!$A$3:$B$10000;2;0);0).

O que quero e preciso é que o Z:\ dessa fórmula se transforme num código que forneça uma referência relativa de endereço. Por exemplo, quando o arquivo principal estiver em C:, essa procura pelo arquivo IDTR.xlsx se dê em C:, ou quando estiver em Meus Documentos, essa procura se dê em Meus Documentos.

Trocando em miúdos, significa dizer que o arquivo IDTR.xlsx sempre seja procurado na mesma pasta onde meu arquivo principal estiver por meio de uma referência dinâmica, algo do tipo:

ActiveWorkbook.Path & "\" & "IDTR.xlsx"

Agradeço muito a quem puder ajudar!

Forte abraço,

Alexandre.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente essa fórmula:

=SE($L$1<>"";PROCV($L$1;INDIRETO("'"&SUBSTITUIR(ESQUERDA(CÉL("filename";A1);PROCURAR("]";CÉL("filename";A1))-1);"[";"")&"'!$A$3:$B$10000");2;0);0)
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Xflapc2,

 

Cara, acho que entendi que o caminho é esse, no entanto, não funcionou na minha planilha...

 

Mas agradeço muito a ajuda!

 

Vou pensar sobre e tentar elaborar ou mudar algo porque está dando aquele erro de #VALOR!

 

Grande abraço,

 

Alexandre.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Beleza, é que não tive como testar na planilha real

 

mas a fórmula que retorna o endereço completo da planilha é:

 

SUBSTITUIR(ESQUERDA(CÉL("filename";A1);PROCURAR("]";CÉL("filename";A1))-1);"[";"")

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mais uma dica, para voce juntar essas formulas voce vai precisar fazer a referencia à range da planilha atraves da formula "INDIRETO".

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×