Ir ao conteúdo
  • Cadastre-se
clikemi

RESOLVIDO Constante em MSQLi não funciona no wamp

Recommended Posts

 

olha o erro...

 

Notice: Use of undefined constant destino - assumed 'destino' in C:\wamp\www\chat2\Class.chat.php on line 56

 

Esse problema só dá no wamp, se eu colocar os arquivos em servidor de teste ele abre normalmente.

 

Estou achando que é alguma extensão PHP que eu tenha que ativar. Tentei ativar todas para saber qual era que dava certo e continua o mesmo erro.

 

Tem como me ajudar??

Compartilhar este post


Link para o post
Compartilhar em outros sites

Erros do tipo notice são erros de "programação não-saudável". Ou seja, não é um erro de programação mas é alguma prática que você não deveria seguir. O erro não acontece no outro servidor porque provavelmente os erros do tipo notice estão suprimidos.

 

Para 'desativar' esse tipo de erro, altere o arquivo php.ini da instalação do wamp na linha error_reporting para E_ALL & ~E_NOTICE, reinicie os serviços do wamp e pronto.

Poste a linha de código da linha 56 (que está dando erro) para vermos o que você está fazendo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Karaca irmão, deu certo sim com o que você falou. eu troquei certinho e deu certinho....valeu!

 

olha os erros ai que você pediu....

 

 



55-       while($res = mysql_fetch_assoc($conversa)){
56-          if(strtolower($res[destino]) !== "sistema" && strtolower($res[destino]) !== "todos" ){
57-               echo "<b>".$res['usuario']." <font color='#00ff00'> -> $res[destino] (reservado) </font>  </b> - ";
58-          }else{
59-                   echo "<b>".$res['usuario']."</b> - ";
60-         }


 

 

o mesmo acontece com esse notice:

 

Notice: Use of undefined constant usuario - assumed 'usuario' in C:\wamp\www\chat2\Class.chat.php on line 108

 

 



107-      while($res = mysql_fetch_assoc($usuarios)){
108-       if($res[usuario] == $_COOKIE[destino]){
        echo "<option selected='selected' value='".$res['usuario']."'>$res[usuario]</option>";
      }else{
        echo "<option value='".$res['usuario']."'>$res[usuario]</option>";
        }




        }

Compartilhar este post


Link para o post
Compartilhar em outros sites

O notice foi gerado porque você está acessando um indice da array mas sem utilizar aspas, então o PHP interpreta como uma constante (que não existe). Como o PHP é lindo de Deus ele ainda "entende" que você fez errado e corrige, mas gera o notice..

 

Bastaria trocar

$res[destino]

por

$res['destino']

 

O mesmo para o $res[usuario].

 

E sucesso :)

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

o meu problema agora é outro.......eu queria que meu chat não carregasse o index.php somente o iframe.php.

 

È assim fiz a pagina iframe.php que tem o próprio chat dentro. Então fiz com que o index.php mostrasse esse chat(iframe.php), mas o problema é que quando eu envio uma mensagem dentro chat o index.php carrega por 500 milisegundos fazendo com que apareça aquela barrinha de carregamento na aba(onde fica o TITLE) do index.php. 

 

Resumindo: Meu objetivo é que o index.php não carregasse visualmente, que ele ficasse fixo.

 

o que fazer???? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Use ajax que resolve o problema.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×