Ir ao conteúdo
  • Cadastre-se
Alexandre Tomé Ferreira

Usar fórmulas de texto para atribuir endereço ao PROCV

Recommended Posts

Boa tarde amigos,

Preciso que a seguinte fórmula "SE($L$1<>"";PROCV($L$1;CONCATENAR("'";INFORMAÇÃO("DIRETÓRIO");"[iDTR.xlsx]IDTR'!$A$3:$D$10000");2;0))" cujo endereço é expresso pelas fórmulas CONCATENAR e INFORMAÇÃO, ambas de texto, aponte sempre para o endereço relativo do diretório do usuário logado na máquina.

Evidentemente, essa expressão acima utilizada está dando erro de #VALUE, pois são tipos de dados diferentes, já que as fórmulas CONCATENAR e INFORMAÇÃO lidam com texto, diferentemente da PROCV.

Será que alguém daria uma luz sobre a solução desse problema? Lembrando que a planilha IDTR é externa à pasta de trabalho em uso, a que contém a fórmula.

Um grande abraço a todos!

Alexandre.

Compartilhar este post


Link para o post
Compartilhar em outros sites

joga a fómuma =contatenar ...

em uma célula qualquer 

e poste aqui o que ela está retornando

so assim da pra ter uma ideia

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então meu camarada,

 

Agradeço muito por sua atenção, o resultado que ela retorna está certo e é exatamente o endereço que eu quero mapear para o resultado do PROCV, no caso: 'C:\Users\alexandre.tome\Documents\[iDTR.xlsx]IDTR'!$A$3:$D$10000. O erro apontado é o de value mesmo e acredito que seja por retornar valor incompatível.

 

Um grande abraço,

 

Alexandre

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia!

 

dei uma lida rapida na duvida, e acho q no procv você vai ter que usar tambem a ormula "indireto" para fazer o procv entender os dados do concatenar, mas mesmo assim, nao querendo desanimar, pela busca ser em outra planilha, acho que o procv nao vai funcionar....

 

talvez funcione se a outra tambem estiver aberta, mas isso so testando...

e experimente testar so com o procv sem essa parte SE($L$1<>"";

 

espero ter ajudado!

 

EDITADO:

 

fiz um teste aqui e funcionou...

 

mas como disse, a outra planilha tem que esta aberta tambem...

 

minha formula ficou assim...

 

=PROCV(A1;INDIRETO(CONCATENAR("'";E3;"[teste.xlsm]Plan1'!$A$1:$D$10000"));2;0)

 

onde E3 é o seu INFORMAÇÃO("DIRETÓRIO")

 

que contem o endereço na rede...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×