Ir ao conteúdo
  • Cadastre-se
anacletotranstusa

Buscar o valor máximo com vários criterios

Recommended Posts

Fórmula q encontrei p/ seu problema:

=SOMARPRODUTO((Tabela_Consulta_de_Excel_Files[Descrição]=Lancamentos!$B3)*(Tabela_Consulta_de_Excel_Files[GARAG_BAIRRO])*(((MÁXIMO(((Tabela_Consulta_de_Excel_Files[Descrição]=Lancamentos!$B3)*Tabela_Consulta_de_Excel_Files[Mês_Ano])*(Tabela_Consulta_de_Excel_Files[Mês_Ano]<=SE(HOJE()>N3;HOJE();N3)))=((Tabela_Consulta_de_Excel_Files[Descrição]=Lancamentos!$B3)*Tabela_Consulta_de_Excel_Files[Mês_Ano])))))

 

Sua base de dados estava com repetição, Linha 8 e 5 (Aventureiro - Transtusa) com mesma data e descrição.

 

Transformei a coluna N em Lançamentos p/ data (não mais texto).

 

Alteração na célula Lançamentos!B3 e C3 a fórmula ficará mais consistente assim e você poderá classificar a Base_Dados com maior liberdade.

=PROCV(A3;Tabela_Consulta_de_Excel_Files;3;0)

 

Lançamento!M28 = 02/03/2015

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa Noite!

Primeiramente quero agradecer a você por me auxiliar no meu problema.

Infelizmente não consegui resolve-lo, mas estou quase lá. 

Anexei um outro exemplo mais simplificado contendo somente um Código de Linha, onde já utilizei sua formula para trazer os valores que pretendo com essa formula. Na coluna "F3 até a F15" inclui a formula, onde me apresentou os valores, porém valores não o esperado, na colula "E3 até E15" apresentei os valores que preciso que a formula me traga.

Conto com sua ajuda, a conclusão desta planilha facilitação e muito meu dia dia.

Abraço!

Novo_Teste.zip

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa Tarde Djunqueira!

 

Novamente venho solicitar seus auxílios. Estou tentando utilizar a mesma formula em uma tabela de controle de estoque, porém preciso incluir mais um critério e não estou conseguindo.

A logica da formula seria a mesma, mostrar o valor do ultimo registro, mas como tenho o tipo "E" para Entrada e "S" para Saída, preciso que a formula me retorno somente os produtos com o tipo "E" de Entrada.

Aguardo!

Cópia de ControledeEstoque.zip

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×