Ir ao conteúdo
  • Cadastre-se
Victor Hugo Silva

Escrever um algoritmo que lê uma matriz M(10,10) e a escreve.

Recommended Posts

Escrever um algoritmo que lê uma matriz M(10,10) e a escreve. Troque, a seguir: 

         a) a diagonal principal com a diagonal secundária 

          B) a linha 5 com a coluna 10. 

 

         Escreva a matriz assim modificada.

 

OBS: consegui fazer só o inicio alguém me ajuda pf - visualg

 

 

 
var valor : vetor [1..10,1..10]de inteiro i,j : inteiroinicio para I de 1 até 10 faça para J de 1 até 10 faça

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você já começou bem, agora só falta ler o  a matriz e imprimir.

 

Para ler, fazemos:

para I de 1 até 10 faca  //contador i é responsável por identificar a linha    para J de 1 até 10 faca //contador j é responsável por identificar a coluna        leia(vetor[i,j])    //comando para ler o elemento      fimparafimpara

para imprimir:

para I de 1 até 10 faca     para J de 1 até 10 faca        escreva(vetor[i,j]) //escreve a matriz     fimparafimpara
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×