Ir ao conteúdo
  • Cadastre-se
roberto cesar fe

RESOLVIDO Procv e mascara

Recommended Posts

Boa noite.

 

Estou com um problema.

Tenho 2 planilhas, uma registra usuários de sistemas (Geral) a outra de funcionarios demitidos (RH).

 

uso como valor de procura o cpf.

 

na planilha 1 (Geral), está formatado o campo cpf como 000"."000"."000"-"00, pois quero digitar apenas números e a formatação faz a sua parte de ajustar para o formado de cpf.

 

na planilha 2 (RH), eu recebo de outro departamento com o campo cpf digitado normalmente com o formato correto.

 

Fiz uma 3ª planilha (Inativar), para ver, dos funcionarios que foram demitidos (RH), quais deles estão na planilha 1(GERAL) com o uso da ProcV

 

Até ai tudo bem, mas a procv da erro (#N/D), e percebi que o CPF da planilha RH não é igual ao da planilha geral pois mesmo eu tendo formatado para que o campo cpf entre com a mascara conforme citado acima, quando eu vejo la na formula esta vem apenas com números. ai dando erro pois os cpfs não ficam iguais (Formatos diferentes).

 

Ex: planila 1 (Geral) CPF: 12345678901 na célula formatada sai 123.456.789-01, mas na formula não atribui os pontos e traço, somente números.

Planilha 2 (RH) o cpf ja vem digitado corretamente: 123.456.789-01

 

Como posso fazer com que meu procv ache o cpf na planilha 1?
tenho como fazer um procv incluindo alguma mascara na minha pesquisa?

 

 

 

 

 

 

teste.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

opção A - utilizando a função SUBSTITUIR (faça o ajuste dos endereços)
 

=PROCV(SUBSTITUIR(SUBSTITUIR(A1;".";"");"-";"")+0;$H$1:$I$100;2)

opção B - utilize o recurso "Localizar/Substituir" (Ctrl+L) para excluir o ponto e o hífen dos CPFs e utilize a sua fórmula atual; poderá aplicar o recurso na própria coluna ou colar em uma coluna auxliar e depois aplicar

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado, ajudou muito o substituir, mas ainda estava dando erro na conversão de texto com o numerico então fiz assim:

 

=PROCV(VALOR(SUBSTITUIR(SUBSTITUIR(RH!F2;".";"");"-";""));Geral!D3:X6;2;FALSO)

Onde primeiro substitui os pontos e hifem por nada e depois converti para numerico e por fim localizava na outra planilha.

 

Agora deu certo.

 

valeu :D

Compartilhar este post


Link para o post
Compartilhar em outros sites

... mas ainda estava dando erro na conversão de texto com o numerico ...

 

 

                 ... A1;".";"");"-";"")+0;...

Talvez você excluiu o zéro da fórmula que sugeri, que transforma em número, equivale à função VALOR.  ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×