Ir ao conteúdo
  • Cadastre-se
Victor Hugo Silva

deem uma olhada noq esta faltando para sair igual ao pedido ajudem

Recommended Posts

Escrever um algoritmo que lê uma matriz M(10,10) e a escreve. Troque, a seguir: 

         a) a diagonal principal com a diagonal secundária 

         cool.png a linha 5 com a coluna 10. 

 

         Escreva a matriz assim modificada

 

Visual g. 

 
algoritmo "10x10"
// Função :
// Autor :
// Data : 05/12/2014
// Seção de Declarações 
var
matr:vetor[1..10,1..10] de real
matr2:vetor[1..10,1..10] de real
l,c:inteiro
inicio
PARA l de 1 ate 10 FACA
PARA c de 1 ate 10 FACA
escreval("Digite o número referente a linha",l," e coluna",c,":")
leia(matr[l,c])
matr2[l,c] <- matr[l,c]
FIMPARA
FIMPARA
escreval("  Matriz Final ")
PARA l de 1 ate 10 FACA
PARA c de 1 ate 10 FACA
escreval("| ",matr2[l,1]," | ",matr2[l,2]," | ",matr2[l,3]," | ",matr2[l,4]," | ",matr2[l,5]," | ",matr2[l,6]," | ",matr2[l,7]," | ",matr2[l,8]," | ",matr2[l,9]," | ",matr2[l,10]," | ")
FIMPARA
fimalgoritmo
 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×