Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
Potro

Ajuda com fórmula SE com células vazias

Recommended Posts

Boa tarde amigos.

 

Estou com uma dúvida: Tenho uma tabela para controlar a entrega mensal das encomendas da empresa, então tenho uma coluna com a data prevista, outra com a data da entrega e a terceira, é uma fórmula SE, onde:

=SE(A2>A1;"Atrasado";"Em dia")

 

O problema é que ele está calculando as células em branco também e, no fim destas colunas, eu estou somando quantos "em dia" tem e quantos "atrasado" tem, para fazer um gráfico de entregas, porém como todas as células não preenchidas ficam como "em dia", a percentagem fica errada.

 

Tem algum modo de esta fórmula não preencher se a célula estiver vazia ou algum modo de eu chegar neste resultado, podendo somar automaticamente quantos em dia e quantos atrasados existem na coluna, sem contar os que estão vazios na data?

 

 

Obrigado

 

Maicon

Editado por Potro

Compartilhar este post


Link para o post
Compartilhar em outros sites

Preciso entender melhor as condições da planilha.

 

A terceira coluna só deve ter algum conteúdo quando A1 e B1, obrigatoriamente, estiverem preenchidas? No caso, quando A2 estiver vazio, você quer que a terceira coluna não exiba nenhum conteúdo?

 

Se for o entendido acima, tente isso:

 

=SE(B1 = "";"";SE(B1>A1;"Atrasado";"Em dia"))

 

Agora, se você quiser criar um terceiro status, mantendo A1 preenchido e B1 sem preencher, pode fazer:

 

=SE(B1 = "";"Ag. Entrega";SE(B1>A1;"Atrasado";"Em dia"))

 

Ainda se quiser criar algo mais inteligente (no bom sentido), faça:

 

=SE(E(A1 <> "";B1 = "");SE(A1 > HOJE();"AG. ENTREGA NO PRAZO";"AG. ENTREGA ATRASADA");SE(B1 >= A1;"ATRASADO";"EM DIA"))

 

Nessa última fórmula, você faz a planilha lhe avisar que a previsão (ainda sem entrega real) ainda está dentro do prazo ou já está atrasada, ao invés de esperar o cálculo da coluna "entrega real" para informar se está "em dia" ou não.

 

Espero que dê certo para o que você precisa.

Editado por minoso

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×