Ir ao conteúdo
  • Cadastre-se
sandrolgp86

Fómula para transferir lista de uma aba para outra no excel

Recommended Posts

Gostaria que me ajudassem a criar uma fórmula ou macro que me permita transferir dados de uma aba para outra, sendo que, conforme a ppanilha anexa, gostaria de que somente os alunos aprovados e dependencia  da aba M1 fossem transferidos para a aba M2, M2 para M3 e etc.

 

SISTEMA SECRETARIA 2015.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

A fórmula para a planilha M2 e replicável p/ as outras desde q feitas as devidas mudanças:

 

=SE(SOMA('M1'!$C$61:$C$62)>='M2'!A5;ÍNDICE('M1'!$B$5:$B$48;SOMARPRODUTO(MAIOR('M1'!$A$5:ÍNDICE('M1'!$A$5:$A$54;'M1'!$C$60)*(('M1'!$S$5:ÍNDICE('M1'!$S$5:$S$54;'M1'!$C$60)="APROVADO")+('M1'!$S$5:ÍNDICE('M1'!$S$5:$S$54;'M1'!$C$60)="DEPENDÊNCIA"));'M1'!$C$61+'M1'!$C$62+1-'M2'!A5)));"")

 

Mas em DADOS GERAIS / MATRICULADOS, linha 60, o somatório (célula C60) deverá ser alterado para:

 

=SOMARPRODUTO((B5:B54<>"")*1)

 

Célula C61 tb deverá ser alterada.

 

Dica:

Os zeros da coluna B na planilha SITUAÇÃO poderiam sumir se você utilizar a regra de formatação 0;;

Editado por DJunqueira

Compartilhar este post


Link para o post
Compartilhar em outros sites

nao entendi a fórmula, mas nao sei se me fiz entender. perdão.

o que eu gostaria era que 

a lista de nomes dos alunos no intervalo (B1:B54) na aba M1 fosse transportada para a mesma posição em M2, e assim por diante. sendo que somente iriam os alunos que estivessem aprovados e em dependência (que aparecem na coluna S). por exemplo se caso um aluno fosse aprovado ele irira aparecer logo na proxima aba.

 

AHHHHH, muito obrigado pela dica, gostei muito.

 

se puder ajudar eu agradeço muito

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×