Ir ao conteúdo
  • Cadastre-se

Recommended Posts

O Invision tem uma tag irmã da

: [codebox]. É a mesma coisa, só que impõe um limite (acredito configurável) de tamanho vertical. Quando excedido, é criada barra de rolagem. No resto, funciona da mesma forma: fonte monoespaçada, múltiplos espaços preservados.

Não está listada no editor WYSIWYG. Porém é interpretada.

O texto a seguir trata-se de

 

repetido várias vezes (note o espaçamento entre as letras).

[codebox] está comendo os espaços e pelo jeito não está limitando o tamanho vertical (ou quem sabe o limite está muito alto?). Enfim, não funciona.

É difícil postar código aqui no fórum. Tomara que no IPB 4.0 realmente fique melhor, Gabriel.

a               b
a ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba ba b

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Marcos FRM
 
O pessoal do suporte fez alguns testes e eu também e verificamos que não há absolutamente nada de errado com o bbcode "codebox". Veja abaixo:
 
 

a                            ba                            ba                            ba                            ba                            ba                            b

 
Note porém que se copio e colo o que há dentro da primeira caixa, a cópia sai sem espaços. O problema não está relacionado, portanto, ao IPB, mas sim ao copiar e colar e/ou ao browser que você usa, que está comendo os espaços na hora de colar. Se você digitar os espaços manualmente o problema não ocorre. Podemos fazer mais testes se quiser. Mas experimenta aí.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vamos ver:

a b

Desligo os controles do editor e posto pelo "BBCode Mode". Nâo usei copiar/colar. Firefox 34, Windows 7.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Marcos FRM você pode colocar aqui uma tela capturada mostrando exatamente os passos que você está usando, pois para mim (e para o suporte) está funcionando 100%, então preciso saber o caminho exato que você está usando para replicar aqui e eventualmente passar ao suporte. Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Testando digitando:

 

teste           teste

 

Testando colando da wikepédia (http://en.wikipedia.org/wiki/List_of_Hello_world_program_examples) usando o chrome  Versão 39.0.2171.95 m:

 

classHELLO_WORLDcreatemakefeaturemakedoprint ("Hello, world!%N")endend

 

Copiando e colando de um editor de texto:

 

#include <16F877a.H>#fuses XT, NOWDT, NOPROTECT, BROWNOUT, PUT, NOLVP#use delay(clock = 4000000) #include <lcd_204.c>    float var1 = 1.5;float var2 = 2.35;float var3 = 3.53;float var4 = 4.55; //===================================void main(){   lcd_init();      printf(lcd_putc, "\f");   delay_ms(500);         while(1)   {        printf(lcd_putc, "\f     %f\n          %f\n               %f\n             %f", var1, var2, var3, var4);            delay_ms(1000);      lcd_putc ("\f");      delay_ms(1000);   }}

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Marcos FRM

@MatheusLPS

 

O problema é justamente esse, em alguns casos os espaços e "enters" usam um código ASCII diferente do normal ou algo assim, mas a culpa é da origem e não do destino (fórum), como mostrado no teste do MatheusLPS acima.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mas que esquisito...

No meu post anterior, digitei o texto, nada de copiar/colar. Vocês estão usando o editor WYSIWYG do fórum?

Compartilhar este post


Link para o post
Compartilhar em outros sites

No meu teste eu usei a "resposta rápida" que aparece aqui no rodapé do tópico! Vamos aguardar a resposta desse teste do MatheusLPS!

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Marcos FRM

 

Usei tanto a resposta rápida quanto o editor completo.

 

edit:

 

Por via das dúvidas:

 

digitando pelo editor completo       espaço da margem esquerda                  mais espaço  menos espaço 

 

Falou

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quero dizer se estão usando o "BBCode Mode" (o botão de chave liga-desliga), que deixa o editor no modo manual.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Todas as tags que uso no fórum são digitadas manualmente. Mas nunca usei esse botao.

 

Nao tinha, que me lembro, no fórum antigo. Então, acostumei a digitar direto.

 

Falou

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×