Ir ao conteúdo
  • Cadastre-se
Fake182

Função se visuAlg

Recommended Posts

Apresentado o problema a seguir,

 

Faça um programa que receba o custo de um espetáculo teatral e o preço do convite desse espetáculo. Esse programa deverá calcular e mostrar a quantidade de convites que devem ser vendidos para que pelo menos o custo do espetáculo seja alcançado.

 

algoritmo "convites"// Função : Mínimo de Convites Vendidos// Data : 16/02/2015varcustoEsp,precoConv,minVendas:realinicio// Entradasescreva ("Insira custo do espetáculo: ")leia(custoEsp)escreva ("Insira o valor do convite: ")leia(precoConv)//ProcessamentominVendas<-(custoEsp/precoConv)//Saídasse (custoEsp % precoConv =0) entaoescreval ("O mínimo de convites vendidos deve ser de: ",(minVendas))senaose (custoEsp % precoConv <>0) entaoescreval ("O mínimo de convites vendidos deve ser de: ",int(minVendas)+1)fimsefimsefimalgoritmo

A minha ideia era fazer com que as divisões sem resto mantenham o número de minVendas, considerando que o valor já foi atigindo, e caso contrário eu tenha o número inteiro de minVendas +1 que seria o número necessário de convites vendidos.

 

O programa está rodando, entretanto ele sempre me indica o valor de int(minVendas)+1; seja a divisão efetuada com ou sem resto... Como eu deveria proceder pra arrumar esse erro ?

 

Obrigado !

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Fake182

 

 

Olha, o que você pode fazer é verificar se o número total de convites obtidos vezes o seu preço paga o custo total do espetáculo; se o valor der inferior, adicione 1 ao número de convites.

 

Note que eu preferi usar o tipo Inteiro para guardar o número de convites (nConvites).

algoritmo "convites"// Função : Mínimo de Convites Vendidos// Data : 16/02/2015var   custoEsp, precoConv : Real   nConvites : Inteiroinicio// Entradasescreva ("Insira o custo do espetáculo: ")leia(custoEsp)escreva ("Insira o valor do convite: ")leia(precoConv)//ProcessamentonConvites <- int(custoEsp / precoConv)se (nConvites * precoConv) < custoEsp então   nConvites <- nConvites + 1fimse//Saídasescreval ("O mínimo de convites vendidos deve ser de: ", nConvites)fimalgoritmo

[ ]'s

Compartilhar este post


Link para o post
Compartilhar em outros sites

@LNW

 

Eu tentei colocar inicialmente como inteiro, mas ele sempre dava erro dizendo que era necessário ser real. Realmente a maneira que você fez ficou mais simplificada.

Obrigado pela ajuda !

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×