Ir ao conteúdo
  • Cadastre-se
Geraldo Fernandes

fazer um algoritmo em pascal que compare o valor de um produto em alguns fornecedores

Recommended Posts

seguinte, tenho um trabalho pra entregar na faculdade que pede pra fazer um algoritmo em pascal que compare o valor de um produto em alguns fornecedores,

Achei um algoritmo aqui na internet mas ele não está em pascal, alguem me ajudaaaaaa preciso de passar ele pra pascal ate 18h de 21/05/2015

 

 

var produto: literal empresa: vetor[1..100] de literal preco: vetor[1..100] de real qtde_emb: vetor[1..100] de inteiro preco_unit: vetor[1..100] de real i, n, menor: inteiro mais_barato: real inicio leia (produto) leia (n) para i de 1 ate n faca escreval ("Informe o nome da empresa fornecedora, o preço e a quantidade na embalagem") leia (empresa[i]) leia (preco[i]) leia (qtd_emb[i]) preco_unit[i] <- preco[i] / qtd_emb[i] fimpara mais_barato <- preco_unit[1] menor <- 1 para i de 2 ate n faca se (mais_barato > preco_uni[i]) então mais_barato <- preco_unit[i] menor <- i fimse fimpara escreval ("O menor preço para o produto: ", produto, " é o da empresa: ", empresa[menor], " com preço: ", preco[menor], " pela embalagem com ", qtd_emb[menor], " produtos, e preço unitário: ", mais_barato) fim_algoritmo 
 
 
 
 

para rodar no programa pascalzim

Compartilhar este post


Link para o post
Compartilhar em outros sites

seguinte, tenho um trabalho pra entregar na faculdade que pede pra fazer um algoritmo em pascal que compare o valor de um produto em alguns fornecedores,

Achei um algoritmo aqui na internet mas ele não está em pascal, alguem me ajudaaaaaa preciso de passar ele pra pascal ate 18h de 21/05/2015

 

 

var produto: literal empresa: vetor[1..100] de literal preco: vetor[1..100] de real qtde_emb: vetor[1..100] de inteiro preco_unit: vetor[1..100] de real i, n, menor: inteiro mais_barato: real inicio leia (produto) leia (n) para i de 1 ate n faca escreval ("Informe o nome da empresa fornecedora, o preço e a quantidade na embalagem") leia (empresa[i]) leia (preco[i]) leia (qtd_emb[i]) preco_unit[i] <- preco[i] / qtd_emb[i] fimpara mais_barato <- preco_unit[1] menor <- 1 para i de 2 ate n faca se (mais_barato > preco_uni[i]) então mais_barato <- preco_unit[i] menor <- i fimse fimpara escreval ("O menor preço para o produto: ", produto, " é o da empresa: ", empresa[menor], " com preço: ", preco[menor], " pela embalagem com ", qtd_emb[menor], " produtos, e preço unitário: ", mais_barato) fim_algoritmo 
 
 
 
 

para rodar no programa pascalzim

 

Olá Geraldo Fernandes,

 

Ainda precisa de ajuda?

 

Então, creio que o prazo já passou né? mas caso queira tentar fazer o programa apenas para aprendizagem (e também até poder demonstrar interesse para o professor etc), é só postar o que já conseguiu fazer e/ou onde está com dúvidas.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×