Ir ao conteúdo
  • Cadastre-se
Lucas Pereira P.

RESOLVIDO Transformar resultados negativos em =0, excel?

Recommended Posts

Gostaria de saber como fazer pra caso C3-B3 for negativo o valor ser convertido em 0. Exemplo:

 

B3 = 200

C3 = 100

Isso daria -100, mas queria que caso isso acontecesse o valor fosse 0, gostaria apenas de conservar os valores positivos 

 

Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Lucas

 

No exemplo que você passou daria 100 e não -100, como você digitou.

 

Experimente usar a fórmula:

 

=SE(C3-B3<0;0;C3-B3)

 

Explicação --> Se C3 menos B3 resultar um número menor que zero, retorna zero, senão, retorna o resultado da fórmula C3 menos B3.

 

Se a resposta foi útil, clique em Curtir.

 

Dê retorno.

 

[]s

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Lucas

 

No exemplo que você passou daria 100 e não -100, como você digitou.

 

Experimente usar a fórmula:

 

=SE(C3-B3<0;0;C3-B3)

 

Explicação --> Se C3 menos B3 resultar um número menor que zero, retorna zero, senão, retorna o resultado da fórmula C3 menos B3.

 

Se a resposta foi útil, clique em Curtir.

 

Dê retorno.

 

[]s

 

 

Eu errei na hora de colocar os valores kkk 

No caso eu queria fazer

=SE(D3*E3+F3<0;0;D3*E3+F3)

 

Onde D3 é um número inteiro, E3 é uma porcentagem  e F3 é outro número inteiro.

-

Suponhamos que:

D3 = -200

E3 = 50% 

F3 = 50

 

Isso daria -50 (eu acho)

Mas caso isso aconteça, queria que o valor ficasse em 0 ou " - " 

 

 

Eu fiz essa formula que coloquei aí em cima, e o resultado ficou em #NAME?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olhei aqui e agora deu certo, muito obrigado mesmo @Patropi :) Me ajudou pra caramba

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×