Ir ao conteúdo
  • Cadastre-se
feross

Procv + Indireto + Concatenar - Busca em planilhas diferentes

Recommended Posts

Olá pessoal.

 

Desde semana passada estou quebrando a cabeça para solucionar um problema aqui na empresa.

 

Seguinte, vamos criar um banco de dados e automaticamente puxa valores de outras planilhas (certificados). 

Pensei na seguinte maneira:

 

Criar um PROCV, por exemplo: Busca o valor A1 cuja a planilha no sistema tivesse com o nome A1.xlsx, ai retornaria os valores de dentro dela.

 

Eu até consegui da seguinte maneira: 

 

                     =PROCV(A2;INDIRETO(CONCATENAR("'H:\[";A2;".xlsx]Plan1'!$A$1:$B$1"));2;0)

 

Usei o CONCATENAR para criar o endereço, e o INDIRETO para transforma-lo em uma referência. 

Funcionou, mas apenas quando a planilha, a ser buscada, esta aberta. Se ela estiver fechada, o PROCV retorna #REF!

 

Há solução para que ele realize a busca em planilhas fechadas???

 

Obrigado a todos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×