Ir ao conteúdo
  • Cadastre-se
Hbadotti

RESOLVIDO Fórmula média mensal

Recommended Posts

Gostaria de saber se tem uma fórmula da qual eu possa calcular a média mensal, ou seja, um fórmula que pegue os valores da coluna Data e os valores da coluna Dados e faça uma média mensal disso

 

Exemplo:

 

 

Data | Dados

14/03 | 10

29/03 | 15

03/04 | 8

25/04 | 22

Logo a média mensal será de ((10+15/2)+(8+22/2))/2 =  13,75

Mas gostaria de saber se existe uma fórmula que detecte o mês e faça esse cálculo...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia

 

Dá para usar a função SOMARPRODUTO junto com a função Mês.

 

Se não conseguir fazer, anexe uma planilha de exemplo demonstrando o resultado esperado.

 

Se a dica foi útil, clique em Curtir.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Consegui amigo!! Muito obrigado!! 


Amigo, estou tendo um problema, eu consegui fazer uma fórmula para achar o gasto médio de um mês, mas gostaria de fazer uma fórmula do qual eu consiga fazer o gasto médio mensal durante todo o periodo revisado...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Anexei minha planilha da qual estou trabalhando agora... Gostaria de criar essa fórmula para a tabela da aba "banco de dados", a fórmula basicamente pegaria desde a primeira data até a data atual (hoje), somaria todos os valores e dividiria pelo número de meses transcorridos...

Controle Combustivel.rar

Compartilhar este post


Link para o post
Compartilhar em outros sites

Habadotti

 

Se os teus dados estão tabulados por dia, como você quer dividir por meses.

Para facilitar o entendimento, você deveria ter demonstrado manualmente no exemplo o que você deseja, pois esta bem confuso.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Desculpe, não me atentei a esse detalhe, mas basicamente eu quero com esses valores que estão em DD/MM/AAAA fazer uma média diária e uma média mensal, isso é possível?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Para fazer a média até a data atual ( vai atualizando, conforme novo dia) use a fórmula abaixo:

 

=SOMARPRODUTO((A2:A10<=HOJE())*(G2:G10))/SOMARPRODUTO(--(A2:A10<>""))

 

Soma os valores de G2 até G10 onde no intervalo de A2 até A10 que a data seja menor ou igual a data de hoje, dividido pelas células não vazias de A2 até A10.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Para fazer a média até a data atual ( vai atualizando, conforme novo dia) use a fórmula abaixo:

 

=SOMARPRODUTO((A2:A10<=HOJE())*(G2:G10))/SOMARPRODUTO(--(A2:A10<>""))

 

Soma os valores de G2 até G10 onde no intervalo de A2 até A10 a data seja menor ou igual a data de hoje, dividido pelas células não vazias de A2 até A10.

 

[]s

 

Deu certo amigo! Só que eu não consegui interpretar essa fórmula, como também a anterior que você me ensinou, como por exemplo:

 

Para que serve isso "--" da parte (--(A2:A10<>""))

Quando você usa <> significa maior ou menor?

Quando você usa <=, significa menor igual? Isso seria uma condição na hora que você usou "A2:A10<=HOJE()"?

Compartilhar este post


Link para o post
Compartilhar em outros sites

<>"" significa diferente de vazio. ( maior e menor juntos, significa diferente)

<= significa menor ou igual

 

"A2:A10<=HOJE() --> essa eu expliquei logo após a fórmula, inclusive detalhei a fórmula inteira.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

<>"" significa diferente de vazio. ( maior e menor juntos, significa diferente)

<= significa menor ou igual

 

"A2:A10<=HOJE() --> essa eu expliquei logo após a fórmula, inclusive detalhei a fórmula inteira.

 

[]s

Sim! Eu entendi essa parte, mas não entendi o porque serve esses 2 traços ( -- ).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Hbadotti

 

Como eu já te indiquei, pesquisando no Google, você irá encontrar tutoriais sobre qualquer função do Excel, inclusive sobre SOMARPRODUTO.

 

A função SOMARPRODUTO não trabalha com o resultado em si, ela utiliza Verdadeiro ou Falso.

Quando um critério é satisfeito é considerado V e quando não é satisfeito F.

Se eu usar um sinal de menos equivale a transformar V em -1, sendo que dois sinais de menos transformam em +1, pois equivalem a -(-1)

 

Se você pesquisar sobre a função verá que existem várias formas de montar uma fórmula com a função SOMARPRODUTO.

e que essa com 2 traços é apenas uma delas. Cada caso é um caso.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×