Ir ao conteúdo
  • Cadastre-se
marcos21

traduçao de c para visual g

Recommended Posts

galera to querendo traduzir para visual g meu prof quer que seja no visualg,

fiz no c é deu certo tudo mas no visualg não consigo fazer o comando 

ja temtei comando repetir ate entre outros mas não funcionou .

 

 

 




printf("Deseja calcular as raizes de outra equacao?\n");
    printf("digite (1) para sim e (0) para não: ");
    scanf("%d", &continua);
  }//while


}//fim



 

 

 



visual g
var
a, b, c, respPonten, respDelta, delta, x, x1, x2 : real
resposta : caractere
inicio
escreva("Digite A: ")
leia(a)
escreva("Digite B: ")
leia(
escreva("Digite C: ")
leia(c)


respPonten <- ( b ^ 2)
delta <- ( respPonten - 4 * a * c )
se (delta > 0) então


   respDelta <- raizq(delta)
   x1 <- ( ( - b + respDelta) / (2 * a) )
   x2 <- ( ( - b - respDelta) / (2 * a) )


   resposta <- "x' = " + numpcarac (x1) + " x'' = " + numpcarac(x2)
senao
   se (delta = 0) então
      x <- ( - b / 2 * a )
      resposta <- " S {x' e x''} = " + numpcarac(x)
   senao
      se (delta < 0) então
         resposta <- "Essa equação é inválida, delta não pode ser menor que (zero)!"
      fimse
   fimse
fimse
escreva( resposta ) '''


C

 



#include <stdio.h>
#include <math.h>
main(){
  //escreva Equações do 2º Grau!
  printf("Equações do 2º Grau!");


  //declare a, b, c, x',x'' : real
  float a,b,c,x1,x2;
  /*continua é uma variavel booleana que em que 1 é
    verdadeiro e 0 é falso*/
  int continua;
  continua = 1; //inicializamos a variavel como verdadeira


  while(continua){
    //escreva "Digite o valor de a"
    printf("Digite o valor de a: ");
    scanf("%f",&a);


    //escreva "Digite o valor de b"
    printf("Digite o valor de b: ");
    scanf("%f",& ;


    //escreva "Digite o valor de c"
    printf("Digite o valor de c: ");
    scanf("%f",&c);


    if( (b*b-4*a*c) >= 0){
      //x'<-[-b+rad(b,2)-4*a*c]/2
      x1=(-b+sqrt(pow(b,2)-4*a*c))/(2*a);


      //x''<-[-b-rad(b,2)-4*a*c]/2
      x2=(-b-sqrt(pow(b,2)-4*a*c))/(2*a);


      //escreva x',x''
      printf("x1 é igual a %f e x2 é igual %f\n\n",x1,x2);
    }else
      printf("Esta equacao nao possui raizes reais!\n\n");


    printf("Deseja calcular as raizes de outra equacao?\n");
    printf("digite (1) para sim e (0) para não: ");
    scanf("%d", &continua);
  }//while


}//fim

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×