Ir ao conteúdo
  • Cadastre-se
Laiston Hss

Copiar e Colar aquivo desktop.ini não funciona. Por que?

Recommended Posts

ola amigos, venho buscar ajuda para sanar uma duvida que me atormenta à algum tempo. 
Bom minha situação e e seguinte: 
Tenho um coleção de filmes , series , livros  e etc., armazenados no meu hd. Estou personalizando as pastas com ícones dos respectivos conteúdos. Afim de manter a aparência da pasta apos personalizada , independente de pra onde eu mova a mesma. segui as intrusões de outro tópico aqui do fórum, 
 
http://forum.clubedohardware.com.br/topic/396337-como-posso-colocar-um-ícone-fixo-em-minhas-pastas/
 
Bem isso funcionou perfeitamente, agora posso mover as pastas sem perder as configurares de personalização. :D
 
porém; como são muitas pastas eu tentei copiar e colar o aquivo "desktop.ini" para as outras pastas.Mas não funciona, o arquivo desktop.ini esta desta forma.

[.ShellClassInfo]IconResource=ShowImage.ico,0[ViewState]Mode=Vid=FolderType=Generic

MAS, este parâmetro do destop.ini funciona; apenas apos fazer a personalização manualmente: botão direito>"Propriedades">"Personalizar">"Alterar ícone">"Procurar">B:\pasta\pasta\pasta\showimage.ico

afim de manter o a configuração eu apago parte do endereço do ícone mantendo somente o nome do mesmo, uma vez que o icone esta dentro da pasta a ser personalizada, e os ícones tem o mesmo nome apenas endereços diferentes.

 

alguém saberia me dizer por que não funciona quando eu copio e colo o destop.ini ou se os paramentos estão errados nesse caso?Ou outra sugestão para personalizar varias pasta ( 250 pastas )de forma mais fácil q fazer o caminho manual uma-a-uma?

 

Desculpe se não fui muito claro , ou se postei no local indevido. como já tentei varias formas passei o máximo de informação possível do meu problema. Obrigado

Compartilhar este post


Link para o post
Compartilhar em outros sites
Bom. achei a  solução paro o problema do arquivo desktop.ini .
apos copiar e colar ele de uma pasta para outro com o codigo:
 
[.ShellClassInfo]IconResource=ShowImage.ico,0
 
e necessário adicionar a pasta onde copiei o desktop.ini o atributo (somente leitura) ;)
estou usando um bat pra fazer esse atributo segue o codigo :
 
@echo off set aff=%~dp0attrib +r "%aff%"

porém estou com dificuldade para acertar isso . a variável q eu criei esta armazenando o carácter  \ no fim do caminho do diretorio.  

 

 

post-780418-0-28618300-1442156766_thumb.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Laiston,

Você conseguiu resolver o problema?

Estou criando um Bat que cria uma pasta e cria um arquivo desktop.ini dentro dessa pasta com suas configurações. Mas estou deparando com o problema do não funcionamento do arquivo desktop.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×