Ir ao conteúdo
  • Cadastre-se
Vinicius Eduardo_773747

gostaria de saber como fazer pra esse algoritmo reiniciar automaticamente no final (tipo, pra n aparecer o "fim da execução do programa"

Recommended Posts

Bom dia, gostaria de saber como fazer pra esse algoritmo reiniciar automaticamente no final (tipo, pra n aparecer o "fim da execução do programa", mas ele começar de novo automaticamente) tem como fazer?

Algoritmo "colete"// Disciplina  :// Professor(a):// Descrição   :// Autor(a)    :// Data atual  :Vara: inteiroInicioEscreval (" _______________________________________________")Escreval ("|                                               |")Escreval ("|  Digite um numero para saber a cor do colete  |")Escreval ("|_______________________________________________|")escreval(" _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ ")escreval("|-Digite 1 para Setor T.I                               |")escreval("|-Digite 2 para Backoffice operacional                  |")escreval("|-Digite 3 para Trafego                                 |")escreval("|-Digite 4 para Recursos Humanos                        |")escreval("|-Digite 5 para Supervisão                              |")escreval("|-Digite 6 para Operador de Telemarketing               |")escreval("|-Digite 7 para Jovem Aprendiz                          |")escreval("|-Digite 8 para Gerência                                |")escreval("|-Digite 9 para Monitoria                              |")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")leia (a)se (a=1) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|     Azul Escuro       |")escreval("|Obrigado pela consulta!|")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=2) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|          Azul         |")escreval("|Obrigado pela consulta!|")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=3) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|   Verde fluorecente   |")escreval("|Obrigado pela consulta!|")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=4) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|         Verde         |")escreval("|Obrigado pela consulta |")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯  ")senaose (a=5) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|         cinza         |")escreval("|Obrigado pela consulta |")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=6) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|      Vermelho         |")escreval("|Obrigado pela consulta |")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=7) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|         Bege          |")escreval("| Obrigado pela consulta|")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=8) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|        Branco         |")escreval("| Obrigado pela consulta|")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaose (a=9) entãoescreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")escreval("|        Laranja        |")escreval("| Obrigado pela consulta|")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senaoescreval("Colete não encontrado")fimsefimsefimsefimsefimsefimsefimsefimsefimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim. Utilize uma estrutura de repetição.

 

 

 

Obs. 1: Mantenha seu código sempre identado. Exemplo:

Algoritmo "colete"// Disciplina  :// Professor(a):// Descrição   :// Autor(a)    :// Data atual  :Var  a: inteiroInicioEscreval (" _______________________________________________")Escreval ("|                                               |")Escreval ("|  Digite um numero para saber a cor do colete  |")Escreval ("|_______________________________________________|")escreval(" _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ ")escreval("|-Digite 1 para Setor T.I                               |")escreval("|-Digite 2 para Backoffice operacional                  |")escreval("|-Digite 3 para Trafego                                 |")escreval("|-Digite 4 para Recursos Humanos                        |")escreval("|-Digite 5 para Supervisão                              |")escreval("|-Digite 6 para Operador de Telemarketing               |")escreval("|-Digite 7 para Jovem Aprendiz                          |")escreval("|-Digite 8 para Gerência                                |")escreval("|-Digite 9 para Monitoria                              |")escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")leia (a)se (a=1) então  escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")  escreval("|     Azul Escuro       |")  escreval("|Obrigado pela consulta!|")  escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")senao  se (a=2) então    escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")    escreval("|          Azul         |")    escreval("|Obrigado pela consulta!|")    escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")  senao    se (a=3) então      escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")      escreval("|   Verde fluorecente   |")      escreval("|Obrigado pela consulta!|")      escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")    senao      se (a=4) então        escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")        escreval("|         Verde         |")        escreval("|Obrigado pela consulta |")        escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯  ")    senao      se (a=5) então        escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")        escreval("|         cinza         |")        escreval("|Obrigado pela consulta |")        escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")    senao      se (a=6) então        escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")        escreval("|      Vermelho         |")        escreval("|Obrigado pela consulta |")        escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")    senao      se (a=7) então        escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")        escreval("|         Bege          |")        escreval("| Obrigado pela consulta|")        escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")    senao      se (a=8) então        escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")        escreval("|        Branco         |")        escreval("| Obrigado pela consulta|")        escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")    senao      se (a=9) então        escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")        escreval("|        Laranja        |")        escreval("| Obrigado pela consulta|")        escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")    senao      escreval("Colete não encontrado")    fimse    fimse    fimse    fimse    fimse    fimse    fimse  fimsefimalgoritmo

Obs. 2: Devido essa característica de se/senao/se em sequência, seria melhor utilizar o CASO.

 

Obs. 3: Existem muitas repetições que podem ser evitadas, ou seja, das 4 linhas, 3 são iguais para todos os casos. Sugiro duas formas para tentar ajustar isso:

1- impriime a primeira, depois seleciona (se) a mensagem da cor, depois exibe as duas últimas;

2- usa uma variável auxiliar para conter o "texto" da cor, daí imprimi uma vez só todo o "quadro" utilizando essa variável.

 

***

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×