Ir ao conteúdo
  • Cadastre-se
Vinicius Eduardo_773747

RESOLVIDO Como fazer?

Recommended Posts

Bom dia, gostaria de saber como fazer pra esse algoritmo reiniciar automaticamente no final (tipo, pra n aparecer o "fim da execução do programa", mas ele começar de novo automaticamente) tem como fazer?

 

Algoritmo "colete"
// Disciplina  :
// Professor(a):
// Descrição   :
// Autor(a)    :
// Data atual  :
Var

a: inteiro


Inicio

Escreval (" _______________________________________________")
Escreval ("|                                               |")
Escreval ("|  Digite um numero para saber a cor do colete  |")
Escreval ("|_______________________________________________|")
escreval(" _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ ")
escreval("|-Digite 1 para Setor T.I                               |")
escreval("|-Digite 2 para Backoffice operacional                  |")
escreval("|-Digite 3 para Trafego                                 |")
escreval("|-Digite 4 para Recursos Humanos                        |")
escreval("|-Digite 5 para Supervisão                              |")
escreval("|-Digite 6 para Operador de Telemarketing               |")
escreval("|-Digite 7 para Jovem Aprendiz                          |")
escreval("|-Digite 8 para Gerência                                |")
escreval("|-Digite 9 para Monitoria                              |")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
leia (a)
se (a=1) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|     Azul Escuro       |")
escreval("|Obrigado pela consulta!|")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=2) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|          Azul         |")
escreval("|Obrigado pela consulta!|")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=3) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|   Verde fluorecente   |")
escreval("|Obrigado pela consulta!|")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=4) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|         Verde         |")
escreval("|Obrigado pela consulta |")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯  ")
senao
se (a=5) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|         cinza         |")
escreval("|Obrigado pela consulta |")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=6) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|      Vermelho         |")
escreval("|Obrigado pela consulta |")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=7) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|         Bege          |")
escreval("| Obrigado pela consulta|")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=8) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|        Branco         |")
escreval("| Obrigado pela consulta|")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
se (a=9) então
escreval("|¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯|")
escreval("|        Laranja        |")
escreval("| Obrigado pela consulta|")
escreval(" ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ¯ ")
senao
escreval("Colete não encontrado")
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tem um comando que repete tudo o que estiver dentro dele, é tipo assim:

 

//enquanto a for diferente de 0, vai repetir tudo o que estiver entre repete e fimrepeterepete (a !=0)...fimrepete;
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×