Ir ao conteúdo
  • Cadastre-se
CLAYTON GONÇALVES

RESOLVIDO EXCEL SOMANDO ERRADO

Recommended Posts

Galera, estou com um problema no excel que por mais inacreditável que isto soe, me parece que a função soma não está funcionando.

quando somo três valores específicos, estes dão zero, porém se adiciono outro zero na soma já não dá mais zero.

Já conferi o formato e todas as células estão como número.

Sei que o erro é muito pequeno porém preciso que a célula dê zero para inserir uma formatação condicional e não posso arredondá-la.

 

Caso possam me ajudar...... Valeu.

ERRO DE SOMA.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Patropi, boa noite. Muito obrigado pela resposta.

Tentei no formato que você me indicou e com ele mesmo a célula estando vazia não zerou.

Mas em todo o caso esta solução não me é útil poque a planilha que enviei é apenas um exemplo na planilha real tenho que somar umas trezentas células várias vezes então preciso criar a função soma arrastando o mouse. Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

César Platz, boa noite. Muito obrigado pela resposta.

O erro continua estou reenviando seu arquivo apenas aumentei o número de casas decimais das células em que você inseriu a fórmula (assim o erro aparece). No meu arquivo preciso trabalhar com um resultado exato.

Experimente apagar o zero da D1 assim a soma vai zerar. Mas como este zero pode interferir na soma???????????????

Abraço

ERRO DE SOMA corrigida.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

clayton

 

Neste caso utilize a função SOMASE.

Copie sem o sinal de igual e cole na célula E1, depois digite o igual.

 

=SOMASE(A1:D1;"<>""")

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Patropi, bom dia. Muito obrigado pela resposta.

Testei com a função SOMASE no formato que me indicou e o erro persistiu. Da forma que montei a soma deu resultado errado com e sem o zero. Envio o arquivo anexo caso queira dar uma olhada. Abraço. 

TESTE SOMASE.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim, esse problema existe, Mas qual é o seu objetivo? Você precisa mesmo desse nível de precisão? Geralmente eu arredondo o resultado da soma para o número de casas decimais necessárias.

 

Ex:

=ARRED(SOMASES(A8:D8;A8:D8;"<>""";A8:D8;"<>"&0);4)
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Clayton

 

Agora que entendi, antes eu estava entendendo que você não queria que desse zero, por isso, que minhas sugestões não atendiam.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Sim, esse problema existe, Mas qual é o seu objetivo? Você precisa mesmo desse nível de precisão? Geralmente eu arredondo o resultado da soma para o número de casas decimais necessárias.

 

Ex:

=ARRED(SOMASES(A8:D8;A8:D8;"<>""";A8:D8;"<>"&0);4)

Wendell, boa tarde.

Muito obrigado, a função ARRED resolveu. Meu objetivo é um problema de balanço de massa de mecânica dos fluidos, preciso somar várias vezes uns trezentos resultados diferentes em uma iteração. Por mim não tinha problema a célula dar zero absoluto ou este número infinitesimal, o problema é que posteriormente vou inserir uma formatação condicional que separará as células que deram zero das que não deram e o excel mesmo com poucas casas decimais não reconhece a célula com este erro como sendo zero. Obrigado novamente.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×