Ir ao conteúdo
  • Cadastre-se

retornar em uma tabela (células) a separação mensal de qtde de celulas


Visitante
Ir à solução Resolvido por Visitante,

Posts recomendados

Olá, tenho uma planilha com duas colunas, uma de datas diversas, e outra de "Liquidado" e célula vazia para "Não liquidado" , precisava retornar em uma tabela (células) a separação mensal de qtde de celulas vazias, ou seja , da coluna de que terá escrito liquidado nas linhas ou em branco (para os não liquidados) , quantas células que estão em branco(vazias) por Mês, alguém poderia me auxiliar? Obrigado

 

 

 

post-786694-0-44705100-1446261885_thumb.
 

 

post-786694-0-44705100-1446261885_thumb.

Link para o comentário
Compartilhar em outros sites

Boa tarde Patropi, primeiramente MUITO OBRIGADO pela resposta e apoio!

Então, a fórmula fez exatamente o que era pra ser feito na planilha que postei em termos de função e ideia, no entanto eu iria utilizar ela em um outro arquivo do excel.

Neste arquivo , eu tenho uma base de dados com as mesmas informações da tabela que anexei e você conseguiu desenvolver a fórmula (retornar o número de células VAZIAS por MÊS em uma outra tabela com base no mês).

Tentei usar a fórmula exatamente como feito por você, apenas trocando os intervalos de dados, e acabou que não funcionou.

 

Vou anexar o arquivo, para se possível você dar uma olhada...

a planilha do arquivo é a "testeee" , a base da dados é a tabela desta planilha "RESUMO GERAL" e para onde quero retornar a contagem das células vazias é a "RELATÓRIO TESTE" (Coluna "Total B.O Não liquidado" , os MESES estão na tabela "RESUMO GERAL" na coluna F3 e as células vazias/liquidados na coluna F21

 

Obrigado, e desculpe pela confusão e problemática! hehe.

plan PROBL.xlsx

Link para o comentário
Compartilhar em outros sites

  • Membro VIP

Boa noite Felipe

 

Eu apliquei uma fórmula com a função SOMARPRODUTO e outra utilizando a função CONT.SES e não funcionou na planilha Testee.

Crie uma nova planilha e digitei os dados nas mesmas células e as fórmulas funcionaram perfeitamente.

 

Baixe a planilha e veja que na Plan2 as formulas funcionam.

 

31_10_15_Contar com Condições V.2 Patropi.xlsx

 

Se foi útil, clique em Curtir.

 

Dê retorno.

Link para o comentário
Compartilhar em outros sites

Valeu de novo, Patropi!

Então, testei aqui de todas as formas também e nada, tentei até criar uma nova tabela igual a da planilha anterior e deu uns problemas.

Testei a sua plan, e ficou ok, porém na hora de apagar os dados , tenho de selecionar a opção "Limpar Conteúdo" e não apenas dar um del ou a tecla de apagar...

Enfim, obrigado por todo o apoio, eu jamais chegaria na fórmula que você chegou....

Se não fosse tão abusivo da minha parte, na coluna Fornecedores , desta mesma Planilha que não deu certo a questão dos dados vazios, eu usei no total geral a fórmula matricial "(ÍNDICE($D$28:$D$61;CORRESP(MÁXIMO(CONT.SE($D$28:$D$61;$D$28:$D$61));CONT.SE($D$28:$D$61;$D$28:$D$61))))" , até ai tudo bem , ele me retornou qual foi o fornecedor que mais apareceu entre todas as datas... Porém estava tentando colocar por mês, seria possível aliar com a fórmula do DATA.TEXTO , ou alguma outra coisa para ver qual o fornecedor máximo de cada mes? Obrigado

E obrigado novamente pelo suporte!

Link para o comentário
Compartilhar em outros sites

Olá, Felipe. Tentando ajudar.

 


... a planilha do arquivo é a "testeee" , a base da dados é a tabela desta planilha "RESUMO GERAL" e para onde quero retornar a contagem das células vazias é a "RELATÓRIO TESTE" (Coluna "Total B.O Não liquidado" , os MESES estão na tabela "RESUMO GERAL" na coluna F3 e as células vazias/liquidados na coluna F21

 

 

Experimente a fórmula abaixo em 'D11' e arraste para baixo.

=SOMARPRODUTO((MÊS($C$28:$C$65)=LIN(A1))*(ANO($C$28:$C$65)=$F$8)*($U$28:$U$65=""))

obs. as células 'U28' e 'U62' "parecem" vazias mas há um espaço em cada uma, por isso não são consideradas pela fórmula.

 

 

 

 

... na coluna Fornecedores , desta mesma Planilha ... qual o fornecedor máximo de cada mes?

 

Não encontrei na sua planilha a coluna 'Fornecedores'.

Me parece que você quer saber qual o nome do intervalo 'D28:D65' que aparece mais vezes para cada mês/ano do intervalo 'C28:C65', seria isso?

Onde você quer os resultados?  Em caso de empate, o que deseja fazer?

Indique alguns dos resultados esperados.

Link para o comentário
Compartilhar em outros sites

Boa tarde Osvaldo, Muitíssimo obrigado! Exatamente como pedido :aplausos: , mesmo que com o empecilho da questão do "limpar células" , já automatizou da forma que eu precisava!

 

Quanto ao processo dos fornecedores seria isto mesmo, "qual o nome do intervalo 'D28:D65' que aparece mais vezes para cada mês/ano do intervalo 'C28:C65'"

Eu iria aplicar esta fórmula no intervalo 'F11:F22'

Para achar o que aparece mais vezes no total geral sem levar em conta mes/ano eu utilize a matricial =(ÍNDICE($D$28:$D$61;CORRESP(MÁXIMO(CONT.SE($D$28:$D$61;$D$28:$D$61));CONT.SE($D$28:$D$61;$D$28:$D$61)))) , não consegui adpata-la ou criar uma nova fórmula que fizesse por mês/ano...

Link para o comentário
Compartilhar em outros sites

  • Solução

Experimente a fórmula matricial abaixo em 'F11' e arraste para baixo.

=ÍNDICE($D$28:$D$65;MODO(SE(MÊS($C$28:$C$65)=LIN(A1);SE(ANO($C$28:$C$65)=$F$8;CORRESP($D$28:$D$65;$D$28:$D$65;0)))))

obs. a fórmula poderá retornar #N/D em algumas situações como inexistência de registro para o mês, registro único para o mês, ...

Link para o comentário
Compartilhar em outros sites

Visitante
Este tópico está impedido de receber novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Ebook grátis: Aprenda a ler resistores e capacitores!

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!