Ir ao conteúdo
  • Cadastre-se
João Paulo Farias Chica

Procv para dois valores procurados

Recommended Posts

Ola a todos.

Gostaria de uma enorme ajuda para criar uma fórmula PROCV para dois valores procurados.

 

Exemplo:  

 

Planilha 1

nome data Valor Buscado
joão 07/03/2016              1
maria 08/03/2016              2
josé 09/03/2016              3
Carol 10/03/2016              4
Paulo 11/03/2016              5
maria 12/03/2016              6
joão 13/03/2016              7
Carol 14/03/2016              8
João 15/03/2016              9
José 16/03/2016              10

 

 

Planilha 2

nome procv
joão  
maria  
josé  
Carol  
Paulo  

 

Obs.: gostaria que a fórmula buscasse o valor com a maior data de cada nome. No caso do nome João seria 9.  

 

Abraço a todos!!!

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você está editando a planilha 2 usando a base do procv na planilha 1 certo? Ponha:

 

=procv([célula desejada];[planilha 1];[coluna x à coluna x];3;0). 

 

Você disse querer buscar a maior data, só usar a classificação por data.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado pelo retorno SeL_.

Mas ainda não esta dando certo aqui pra mim.

 

O que eu quero que a fórmula busque é primeiro o nome, mas como temos alguns nomes repetidos, que ela busque de forma secundária a maior data referente ao nome, e ai sim, retornar com o número da coluna "Valor Buscado".

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde João Paulo

 

Seja bem-vindo ao fórum!

 

Dá para fazer usando fórmula matricial.

Confira na planilha.

Mas não se esqueça, no final da formula, em vez de teclar ENTER tecle CTRL+SHIFT+ENTER, que automaticamente são inseridas chaves, no início e no final da fórmula.

 

Se foi útil, clique em Curtir

10_03_16_Maior data com critério-Patropi.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@João Paulo Farias Chica

 

Considerando a tabela a partir de 'A1' e o nome em 'H1', experimente a fórmula matricial abaixo

=ÍNDICE(C2:C11;CORRESP(1;(A2:A11=H1)*(B2:B11=MÁXIMO(SE(A2:A11=H1;B2:B11)));0))

obs. para inserir como fórmula matricial, após colar a fórmula na célula aperte 'F2' e em seguida aperte 'Ctrl+Shift+Enter' juntas.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Com a resposta do mestre Osvaldo é que eu fui entender que ele quer o valor e não a maior data.

É por isso que eu tenho evitado responder tópicos que não venham acompanhados de anexo.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

A fórmula que postei acima vale se ela estiver na mesma planilha em que estiver a tabela.

 

Se a tabela estiver na Plan1 e a fórmula na Plan2, conforme o arquivo que o Mestre Patropi disponibilizou, então coloque a fórmula abaixo em 'B2' da Plan2 e arraste.
 

=ÍNDICE(Plan1!$C$2:$C$11;CORRESP(1;(Plan1!$A$2:$A$11=A2)*(Plan1!$B$2:$B$11=MÁXIMO(SE(Plan1!$A$2:$A$11=A2;Plan1!$B$2:$B$11)));0))

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×