Ir ao conteúdo
  • Cadastre-se
L3M35

Encontrar valores repetido com procv e somar

Posts recomendados

Olá, estou com um problema que já está me deixando careca (mais).

Tenho duas planilhas: uma com itens adquiridos (entrada), e outra de vendas (saída).

A planilha de entrada é (de forma sintética) assim:

 

B                    C                  D                   E

SKU               NOME          PREÇO         UNIDADES

0001              Caneta         200                2000

0002              Caderno      500                5000

0003              Lápis           150                1500

0001              Caneta        150                1500

0004              Borracha    100                1000

 

Ou seja: um mesmo produto pode ser comprado mais de uma vez no mesmo período, logo vai aparecer duas ou mais vezes, com valores diferentes. Na planilha de venda, o NOME do produto é chamado pelo SKU através de PROCV, fica assim:

 

B                    C                    

SKU               NOME         

0001              Caneta        

0003              Lápis           

0001              Caneta       

0004              Borracha   

 

No B, o SKU é digitado, e no C está a fórmula =PROCV(C3;Compras!C$4:T$254;17;0)

Mas eu preciso chamar também o preço total do produto no período, ou melhor, somar o PREÇO de todas as ocorrências de "Caneta", para depois obter o preço individual. Até tentei pegar o campo do PREÇO com o PROCV, mas claro que só pega o primeiro valor.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia L3M35

 

Para isso é só usar a função SOMASE.

 

Exemplo:

 

=SOMASE(Compras!B4:B8;B3;Compras!D4:D8)

Se foi útil, clique em Curtir.

 

Dê retorno.

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado Patropi, eu resolvi usando o SOMASE ontem mesmo, é que estava tão bitolado com PROCV que fiquei procurando soluções complicadas e que não funcionavam.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@L3M35 @Patropi, não consegui resolver. Estou passando pelo mesmo problema. Podem me ajudar?

https://www.clubedohardware.com.br/forums/topic/1157722-encontrar-valores-repetido-com-procv-e-somar/

adicionado 0 minutos depois

Também estou com esta mesmíssima dúvida e gostaria de saber como resolveram este tópico...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite @barbosaleonardo

 

Seja bem-vindo ao fórum!

 

Sim, mas para facilitar anexe um arquivo de exemplo, digitando o resultado esperado.

 

[]s

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Meu amigo, @Patropi... Mas que satisfação a celeridade e boa vontade com a qual interagiu. Uma esperança que se abre no peito e na mente. Irei compartilhar minha planilha aqui para que possa entender. Amanhã de manhã, impreterivelmente. Assim que eu acordar. Aqui é permitido compartilhar contato de wpp? No fórum... MUITO OBRIGADO

Compartilhar este post


Link para o post
Compartilhar em outros sites

ARQUIVO ANEXADO, MEU AMIGO...

Eu gostaria que na planilha de ESTOQUE, os valores de cada produto puxassem a informação da planilha FINANCEIRO, mas com todas as ocorrências de cada produto, somadas! Ele só me retorna a primeira ocorrência.

=SOMA(PROCV(A3;FINANCEIRO!B:D;3;0))

Retorna somente o valor da primeira ocorrência do produto na planilha FINANCEIRO. :(

É o mesmo problema que o amigo @L3M35 enfrentou aí na época.

Não sei como ele solucionou

GESTÃO FINANCEIRA LOVTOY.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vou olhar agora mesmo!!! 😀

adicionado 44 minutos depois

DEU SUPER CERTO, MEU AMIGO. Sei nem como agradecer. Você foi muito rápido em me ajudar.

Fui dormir com o problema e acordei com a solução.

Única coisa que editei foi o número de linhas haha Coloquei logo o limite máximo de "1048576"

                                                                |                                                                            |

                                                                |                                                                            |

                                                               \|/                                                                          \|/
=SOMASE(FINANCEIRO!$J$3:$J$1048576;ESTOQUE!F3;FINANCEIRO!$L$3:$L$1048576)

Para pecar pelo excesso :D

Se tiver algum canal seu, contato, facebook, instagram ou qualquer outro perfil pessoal e profissional. Divulgue.

Será um grande prazer contribuir também divulgando, compartilhando, seguindo etc.

Grande abraço, hacker!

Compartilhar este post


Link para o post
Compartilhar em outros sites

@barbosaleonardo

 

Se quiser usar a coluna toda pode usar a fórmula conforme abaixo, sem estipular linha inicial e final.

Normalmente eu não faço isso, pois pode tornar os cálculos mais lentos.

A função SOMARPRODUTO já não permite usar sem estipular o intervalo.

=SOMASE(FINANCEIRO!B:B;ESTOQUE!A3;FINANCEIRO!D:D)-H3

 

Precisando, volte a postar no fórum.

 

[]s

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!