Ir ao conteúdo
  • Cadastre-se
siqueiraandrei

Excel procura de parte de texto

Recommended Posts

Boa tarde,

Estou com o seguinte problema:

Gostaria de fazer um PROCV para pegar o código do produto no cliente e alimentar outra tabela com o meu código.

Veja o pequeno exemplo abaixo:

Meu código     Código no Cliente

A0362542-1           DB-83

A0362541-5       DF80/DF80X

A0362540-2       BOEMEX30/AA10/GHJ30-X

 

Eu quero fazer uma fórmula para pegar o A0362541-5 onde o Código no Cliente for DF80X.

Só que meus clientes podem ter um, ou vários códigos e os códigos não seguem um tamanho padrão. Único padrão da célula é que todos os códigos no cliente nós separamos por barra.

Alguém tem alguma ideia de como eu posso fazer isso?

 

Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Considerando os "seus códigos" a partir de 'A2' e os "códigos do cliente" a partir de 'B2' e o texto a ser buscado, no seu exemplo DF80X, em 'C1', veja se a fórmula abaixo ajuda.

=ÍNDICE(A2:A4;CORRESP("*"&C1&"*";B2:B4;0))

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal, tentei das duas formas mas usando o asterisco o meu Excel informa que a planilha possui erro.

Pra ficar mais claro segue a minha tabela resumida.

Eu gostaria que aparecesse em B1 da tabela Final, o que está em B6:B48, de acordo com o que está em A na tabela Final, buscando esse texto em A na tabela Referência.
Não sei se estou conseguindo ser claro na minha dúvida.

 

 

Tabela.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia Siqueira

 

Adaptei as formulas sugeridas pelo deejaywesley e pelo Osvaldo para a realidade da tua planilha, onde os dados procurados ficam na outra planilha.

Ambas as sugestões funcionaram.

 

Dê retorno.

 

Se foi útil, clique em Curtir nas nossas respostas.

 

 

14_04_16_PROCV ou ÍNDICE_CORRESP_Patropi.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×