Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Bruno s Farias

Visualg programa de controle de frequencia

Recommended Posts

O programa deverá solicita quant de fun , informar nome do fun , cpf , função , informa beneficios e valor do desconto de cada beneficio , informar o salario do funcionario , regime de contratação (ctl(40hrs), horista(20) se for clt , formar o salario se for horista , informar o valor/hora , quando os func estiver cadastrado , devera aparece uam lista, o usuario , devera escolher um funncionario da lista e informa : horas trabalhadas na 1 , 2 , 3 ,4 semana , programa devera informar se o funcionario tem hora extrea e receber ou se ele esta devendo hora , caso ele tenha hora extre devera ser informado seu salario + o valor dos extra do contrario , informar o salario - o valor devido das horas nao trabalhadas. no final o programa devera emitir o contracheque do  funcionario

 

Nome:

cpf:

salario Bruto :

descontro especificados (beneficios , imposta,..etc)

acrescimo especifico - ( hora extra , decimo terceiro...etc)

salario liquido e receber

 

URGENTE  

 

OBS: EU TENHO ISSO ATE O MOMENTO AJUDEM PF

algoritmo "analise_2"
// Função :
// Autor :
// Data : 12/05/2016
// Seção de Declarações
var
vet:vetor[1..4] de inteiro
opcaosalario,cont:inteiro
continuaCadastrar, listagemVoltarMenu, excluirVoltarMenu:caracter
menu,contadorFuncionarimenuo, i:inteiro
numero,nome:caractere  // defino a variável que guardará o número digitado
compri:inteiro //defino a variável que guardara o comprimento do número digitado
cad1, cad2: inteiro

inicio
escreval("Digite quantidade de funcionario para cadastro no sistema")//  Numero de funcionario para cadastro
leia(cad1)
para cad1 de 1 ate cad2 passo 1 faca
escreva(cad1)
fimpara
escreval("Digite o nome do funcionario") // nome do funciona
leia(nome)  //leia o nome
Escreval ("Digite o cpf: ") // Numero do cpf
leia(numero) // leio o numero do cpf
compri<-compr(numero)  // com a função compr(c:caracter) eu obtenho o número de caractere da variável numero
enquanto compri <> 11  faca // enquanto o comprimento for diferente de 11 eu faço:
escreval("O número digitado deve conter 11 caracteres")
escreva("Digite novamente o cpf: ") // peço o cpf novamente
leia(numero)    // leio o número novamente
compri <- compr(numero)    // aplico a função novamente
fimenquanto // fim do loop (laço)
escreva("Informe funcao do funcionario: ") // funcao do  funcionario Juntamente com salario
escreval()
escreval("1-Programador")
escreval("2-Alista de sistemaAn")
escreval("3-Gerente de projeto")
escreval("4-Diretor de Loja")
leia(opcaosalario)
se opcaosalario = 1 então
escreval("Salario = R$ 1500,00")  // opcaosalario
senao
se opcaosalario = 2 então
escreval("Salario = R$ 2300,00")
senao
se opcaosalario = 3 então
escreval("Salario = R$ 5000,00")
senao
se opcaosalario = 4 então
escreval("Salario = R$ 7500,00")
senao
escreval("Opcao inexistente!") // caso noa estaja no laço informa que é invalido
vetornomeFuncionario[contador]<-nomeFuncionario  //calculo
vetorValorFuncionario[contador]<-opcaosalario    //calculo
fimse
fimse
fimse
fimse
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi Bruno s Farias
  Esse algoritmo que você pretende é bem complexo, tem muita coisa para fazer,sugiro
que você vá fazendo ele aos poucos, você está indo no caminho certo, um erro é esse
para ai no começo não precisa dele;  A entrada de dados está certa, agora é só orga -
nizar essas informações e resolver cada detalhe separadamente.
  

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×