Ir ao conteúdo
  • Cadastre-se
Luc0909

Erro de sintaxe inesperado no visualg

Recommended Posts

Olá a todos :)

Gostaria de saber, para os mais experientes, qual o erro de sintaxe na linha 10.

algoritmo "Porcentagem"
 var
    VA,VB,V3 : Real
inicio
      Escreva ("Informe o número: ")
      Leia (VA)
      Escreva ("Qual a porcentagem que deseja deste número? ")
      Leia (VB)
           V3 <- VA * VB / 100
     Escreva ("Resultado = ",V3)
fimalgoritmo

 

Eu declarei a variável VB como real, no entanto, quando coloco algum número fracionário ( ex.:"1.8") , o programa informa um erro de sintaxe, dizendo que esperava uma expressão real... Poderiam me ajudar ?

Muito Obrigado!

 

Editado por dif
inserir a tag CODE <>

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×