Ir ao conteúdo
  • Cadastre-se
Rafael Leme

Excel inserir linha mas não alterar fórmula

Recommended Posts

Boa tarde galera,

Pessoa estou com um problema, estou fazendo uma planilha simples, nessa planilha contem:

 

Planilha 1:Adicionar dados, que é feito através de um macro;

Planilha 2: Dados, como se fosse uma base de dados, o adicionar dados insere uma linha na tabela específica;

Planilha 3: Buscar dados, apenas uma busca simples com a seguinte função:

 

"{=SEERRO(ÍNDICE(Dados!$B$5:$C$600;MENOR(SE(Dados!$B$5:$B$600=Buscar!$B$4;LIN(Dados!$B$5:$B$600)-4);LIN(Dados!B1));2);"")}

 

porém quando eu adiciono um dados na planilha 1, que fica gravado na planilha 2, a formula altera para seguinte:

 

"{=SEERRO(ÍNDICE(Dados!$B$5:$C$600;MENOR(SE(Dados!$B$6:$B$601=Buscar!$B$4;LIN(Dados!$B$6:$B$601)-4);LIN(Dados!B1));2);"")}"

 

Agradeço que puder me ajudar,

Att.,

 

 

Editado por osvaldomp
adequar o título do tópico

Compartilhar este post


Link para o post
Compartilhar em outros sites

Isso acontece porque você insere a linha na parte de cima da planilha, e neste caso a formula acompanha a linha.

 

Para evitar isso insira apenas as colunas desejadas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×