Ir ao conteúdo
  • Cadastre-se
Arthur Dias

RESOLVIDO Macro excel

Recommended Posts

Preciso criar uma macro ou código onde apos fazer um calculo, encontre nesta planilha o valor mais próximo nas linhas a frente Q/raiz I e logo que me informe o valor referente à y/D na primeira linha.

Sem título.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

@DJunqueira como eu poderia fazer?

@CasaDoHardware o valor procurado está na coluna T "Q/Raiz I", quero achar o valor mais próximo na aba verificação onde está colorido, por exemplo na celula t15  da aba cálculo o valor é 15,22, o valor mais próximo esta na celula AC18 da aba verificação, o diâmetro correspondente é 0,9 da célula B18 e o y/d é 0,7 da célula AC2, queria que esses valores fossem substituídos respectivamente nas celulas J15 e O15.

PLANILHA ESGOTO1.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ordenei os números da matriz Q/raiz(I) em [Tabela ordenada] e com isso fiz um busca por ordem crescente p/ encontrar números digitados na célula F50 com resultado p/ y/D aparecendo em F55.

Os números procurados tb ficam em destaque na tabela.

PLANILHA ESGOTO1.xls

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@DJunqueira Nas celulas n15 a n44 eu preciso de alguma formula onde: na linha montante da coluna N tenha a codição de se B15  por exemplo for igual a "c" que ela faça m15-k15 assim como nessa formula: =SE($B15="c";$M15-$K15), mas se nao, quero que ela pegue a menor jusante correspondente ao trecho correspondente, tem como ajuda nisso?, coloquei agora essa foto pra ver se da pra entender, quero por exemplo que a cota da montante do trecho 10 seja igual a menor cota entre as jusantes 1, 4 e 6

 

PLANILHA ESGOTO.xls

Sem explicação.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites
13 horas atrás, Arthur Dias disse:

@DJunqueira @CasaDoHardwareNas celulas n15 a n44 eu preciso de alguma formula onde: na linha montante da coluna N tenha a codição de se B15  por exemplo for igual a "c" que ela faça m15-k15 assim como nessa formula: =SE($B15="c";$M15-$K15), mas se nao, quero que ela pegue a menor jusante correspondente ao trecho correspondente, tem como ajuda nisso?, coloquei agora essa foto pra ver se da pra entender, quero por exemplo que a cota da montante do trecho 10 seja igual a menor cota entre as jusantes 1, 4 e 6

 

PLANILHA ESGOTO

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mencione a guia, do contrário eu fico na condição de adivinho.

No caso imagino q seja a guia Cálculo.

 

Para te ajudar eu preferia q você me orientasse em termos de linhas e colunas, Montante e Jusante não é propriamente a minha praia.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Seja mais explicito onde você quer buscar determinada informação.

Qual coluna/linha, qual cabeçalho com está exatamente na planilha.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×