Ir ao conteúdo
  • Cadastre-se

Recommended Posts

Boa noite (-:

 

Bem pessoal desculpe se eu estiver postando na área errada...

 

Enfim apesar do desempenho já um tanto limitado pelo bendito modulo proprietario da Nvdia eu por algum motivo prefiro jogar alguns jogos no linux do que no windows(Vai entender o porque)

 

O problema e que recentemente eu fiz uma mudança do manjaro para o fedora 23(kde) e ao instalar o steam ele não inicia com este erro:

 

[ylloluis@localhost ~]$ steam 
Running Steam on fedora 23 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/ylloluis/.local/share/Steam/steam.sh: line 756:  3703 Falha de segmentação  (imagem do núcleo gravada)$STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
[ylloluis@localhost ~]$ 

 

Isso seria a falta de alguma dependência? Os pacotes instalados junto com o steam foram estes aqui:

 

Instalados:
  alsa-lib.i686 1.1.1-1.fc23                  atk.i686 2.18.0-1.fc23                     audit-libs.i686 2.5.1-1.fc23                    avahi-libs.i686 0.6.32-1.fc23                    bzip2-libs.i686 1.0.6-19.fc23                  
  cairo.i686 1.14.2-2.fc23                    cracklib.i686 2.9.1-6.fc23                 cups-libs.i686 1:2.1.3-1.fc23                   cyrus-sasl-lib.i686 2.1.26-25.2.fc23             dbus-libs.i686 1:1.10.8-1.fc23                 
  elfutils-libelf.i686 0.166-1.fc23           elfutils-libs.i686 0.166-1.fc23            expat.i686 2.1.1-1.fc23                         flac-libs.i686 1.3.1-5.fc23                      fontconfig.i686 2.11.94-4.fc23                 
  freetype.i686 2.6.0-3.fc23                  gdk-pixbuf2.i686 2.32.3-1.fc23             gdk-pixbuf2-modules.i686 2.32.3-1.fc23          glib2.i686 2.46.2-1.fc23                         glibc.i686 2.22-16.fc23                        
  gmp.i686 1:6.0.0-12.fc23                    gnutls.i686 3.4.12-1.fc23                  graphite2.i686 1.3.6-1.fc23                     gsm.i686 1.0.13-13.fc23                          gtk2.i686 2.24.30-1.fc23                       
  harfbuzz.i686 1.0.6-1.fc23                  jasper-libs.i686 1.900.1-31.fc23           jbigkit-libs.i686 2.1-4.fc23                    json-c.i686 0.12-6.fc23                          keyutils-libs.i686 1.5.9-7.fc23                
  krb5-libs.i686 1.14.1-6.fc23                libICE.i686 1.0.9-3.fc23                   libSM.i686 1.2.2-3.fc23                         libX11.i686 1.6.3-2.fc23                         libXScrnSaver.i686 1.2.2-9.fc23                
  libXau.i686 1.0.8-5.fc23                    libXcomposite.i686 0.4.4-7.fc23            libXcursor.i686 1.1.14-4.fc23                   libXdamage.i686 1.1.4-7.fc23                     libXext.i686 1.3.3-3.fc23                      
  libXfixes.i686 5.0.1-5.fc23                 libXft.i686 2.3.2-3.fc23                   libXi.i686 1.7.6-1.fc23                         libXinerama.i686 1.1.3-5.fc23                    libXrandr.i686 1.5.0-2.fc23                    
  libXrender.i686 0.9.9-2.fc23                libXtst.i686 1.2.2-5.fc23                  libXxf86vm.i686 1.1.4-2.fc23                    libacl.i686 2.2.52-10.fc23                       libasyncns.i686 0.8-9.fc23                     
  libattr.i686 2.4.47-14.fc23                 libcap.i686 2.24-8.fc23                    libcom_err.i686 1.42.13-3.fc23                  libcurl.i686 7.43.0-6.fc23                       libdatrie.i686 0.2.8-6.fc23                    
  libdb.i686 5.3.28-13.fc23                   libdrm.i686 2.4.66-1.fc23                  libedit.i686 3.1-13.20150325cvs.fc23            libffi.i686 3.1-8.fc23                           libgcc.i686 5.3.1-6.fc23                       
  libgcrypt.i686 1.6.4-1.fc23                 libgpg-error.i686 1.21-1.fc23              libidn.i686 1.32-1.fc23                         libjpeg-turbo.i686 1.4.1-2.fc23                  libnghttp2.i686 1.7.1-1.fc23                   
  libogg.i686 2:1.3.2-4.fc23                  libpciaccess.i686 0.13.4-2.fc23            libpng.i686 2:1.6.19-2.fc23                     libpng12.i686 1.2.56-1.fc23                      libseccomp.i686 2.3.1-0.fc23                   
  libselinux.i686 2.4-4.fc23                  libsndfile.i686 1.0.25-18.fc23             libssh2.i686 1.6.0-4.fc23                       libstdc++.i686 5.3.1-6.fc23                      libtasn1.i686 4.8-1.fc23                       
  libthai.i686 0.1.21-2.fc23                  libtiff.i686 4.0.4-1.fc23                  libtxc_dxtn.i686 1:1.0.1-1.gitef072983.fc23     libuuid.i686 2.28-1.fc23                         libva-intel-driver.i686 1.6.2-1.fc23           
  libvdpau.i686 1.1.1-2.fc23                  libverto.i686 0.2.6-5.fc23                 libvorbis.i686 1:1.3.4-5.fc23                   libwayland-client.i686 1.9.0-1.fc23              libwayland-server.i686 1.9.0-1.fc23            
  libxcb.i686 1.11.1-1.fc23                   libxshmfence.i686 1.2-2.fc23               llvm-libs.i686 3.7.0-4.fc23                     mesa-dri-drivers.i686 11.1.0-3.20151218.fc23     mesa-filesystem.i686 11.1.0-3.20151218.fc23    
  mesa-libEGL.i686 11.1.0-3.20151218.fc23     mesa-libGL.i686 11.1.0-3.20151218.fc23     mesa-libgbm.i686 11.1.0-3.20151218.fc23         mesa-libglapi.i686 11.1.0-3.20151218.fc23        ncurses-libs.i686 5.9-21.20150214.fc23         
  nettle.i686 3.2-1.fc23                      nspr.i686 4.12.0-1.fc23                    nss.i686 3.24.0-1.1.fc23                        nss-softokn.i686 3.24.0-1.0.fc23                 nss-softokn-freebl.i686 3.24.0-1.0.fc23        
  nss-util.i686 3.24.0-1.0.fc23               openldap.i686 2.4.40-14.fc23               openssl-libs.i686 1:1.0.2h-1.fc23               p11-kit.i686 0.23.2-1.fc23                       pam.i686 1.2.1-2.fc23                          
  pango.i686 1.38.1-1.fc23                    pcre.i686 8.38-7.fc23                      pixman.i686 0.34.0-1.fc23                       pulseaudio-libs.i686 7.1-1.fc23.1                sqlite-libs.i686 3.11.0-3.fc23                 
  steam.i686 1.0.0.52-1.fc23                  systemd-libs.i686 222-14.fc23              tcp_wrappers-libs.i686 7.6-81.fc23              xz-libs.i686 5.2.1-3.fc23                        zlib.i686 1.2.8-9.fc23                         

Atualizados:
  mesa-dri-drivers.x86_64 11.1.0-3.20151218.fc23    mesa-filesystem.x86_64 11.1.0-3.20151218.fc23    mesa-libEGL.x86_64 11.1.0-3.20151218.fc23    mesa-libGL.x86_64 11.1.0-3.20151218.fc23     mesa-libgbm.x86_64 11.1.0-3.20151218.fc23   
  mesa-libglapi.x86_64 11.1.0-3.20151218.fc23       nss.x86_64 3.24.0-1.1.fc23                       nss-softokn.x86_64 3.24.0-1.0.fc23           nss-softokn-freebl.x86_64 3.24.0-1.0.fc23    nss-sysinit.x86_64 3.24.0-1.1.fc23          
  nss-tools.x86_64 3.24.0-1.1.fc23                  nss-util.x86_64 3.24.0-1.0.fc23               

 

O que eu devo fazer para tornar o steam executavel no fedora?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Qual placa de video você tem? E qual driver?

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 horas atrás, AmarildoJr disse:

Qual placa de video você tem? E qual driver?

 

E uma Zotac Gtx 750(2Gb) 

 

Estou usando o modulo 361.45

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 horas atrás, anjoed disse:

Qual steam tu instalasse ? Do repositório ou tu baixaste do site deles ? 

 

Infelizmente o site oficial do steam não disponivel no formato do fedora )-: apenas .Deb para os sistemas baseados em debian

 

Eu baixei o steam do repositorio Rpm-fusion 

Compartilhar este post


Link para o post
Compartilhar em outros sites

acesse o terminal e ative o root....

 

execute:

 

dnf remove steam "enter"   ( desinstalar o steam  )

 

dnf autoremove "enter"  ( Remover pacotes perdidos, sem necessidade )

 

dnf config-manager --add-repo=http://negativo17.org/repos/fedora-steam.repo "enter"  ( adicionar repositório do steam para fedora)

 

dnf -y install steam "enter"  ( instalar o steam )

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 07/06/2016 às 09:15, Manjaro disse:

acesse o terminal e ative o root....

 

execute:

 

dnf remove steam "enter"   ( desinstalar o steam  )

 

dnf autoremove "enter"  ( Remover pacotes perdidos, sem necessidade )

 

dnf config-manager --add-repo=http://negativo17.org/repos/fedora-steam.repo "enter"  ( adicionar repositório do steam para fedora)

 

dnf -y install steam "enter"  ( instalar o steam )

 

 

 

Não consigo instalar )-: 

 

[ylloluis@localhost ~]$ sudo dnf install steam
Última verificação de data de vencimento de metadados: 0:11:02 atrás em Thu Jun  9 19:02:40 2016.
Error: nothing provides libva-intel-driver(x86-32) needed by steam-1.0.0.52-2.fc23.i686
(tente adicionar '--allowerasing' a linha de comando para substituir pacotes conflitantes
[ylloluis@localhost ~]$ 

Se eu tento instalar o steam com o repositorio do Rpmfusion ativado o sistema não baixa o steam do repositorio que você passou...

 

E quando eu desativo o Rpmfusion e tento com o este repositorio tenho o erro ja citado )-: 

Compartilhar este post


Link para o post
Compartilhar em outros sites
9 horas atrás, Manjaro disse:

faça o download -> ftp://195.220.108.108/linux/rpmfusion/free/fedora/updates/testing/23/i386/libva-intel-driver-1.6.2-1.fc23.i686.rpm

 

acesse o terminal e como root execute:

 

rpm -ivh  "arquivo baixado.rpm"  enter

 

tente instalar o steam....

 

Citação

[ylloluis@localhost Downloads]$ sudo rpm -ivh libva-intel-driver-1.6.2-1.fc23.i686.rpm   
erro: Dependências não satisfeitas:
       libc.so.6 é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libc.so.6(GLIBC_2.0) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libc.so.6(GLIBC_2.1) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libc.so.6(GLIBC_2.1.3) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libc.so.6(GLIBC_2.3.4) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libc.so.6(GLIBC_2.4) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libdl.so.2 é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libdl.so.2(GLIBC_2.0) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libdl.so.2(GLIBC_2.1) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libdrm.so.2 é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libdrm_intel.so.1 é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libm.so.6 é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libm.so.6(GLIBC_2.0) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libm.so.6(GLIBC_2.1) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libpthread.so.0 é requerido por libva-intel-driver-1.6.2-1.fc23.i686
       libpthread.so.0(GLIBC_2.0) é requerido por libva-intel-driver-1.6.2-1.fc23.i686
[ylloluis@localhost Downloads]$

 

 

O que eu devo fazer?

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 horas atrás, Manjaro disse:

ftp://195.220.108.108/linux/fedora/linux/releases/23/Everything/i386/os/Packages/g/glibc-2.22-3.fc23.i686.rpm

 

instale a biblioteca glibc

 

depois tente instalar o libva-intel e o steam...

Citação

Error running transaction: package glibc-2.22-3.fc23.x86_64 (newer than glibc-2.22-17.fc23.x86_64) is already installed
package glibc-common-2.22-3.fc23.x86_64 (newer than glibc-common-2.22-17.fc23.x86_64) is already installed
package glibc-headers-2.22-3.fc23.x86_64 (newer than glibc-headers-2.22-17.fc23.x86_64) is already installed
package glibc-2.22-3.fc23.i686 (newer than glibc-2.22-17.fc23.x86_64) is already installed
package glibc-devel-2.22-3.fc23.x86_64 (newer than glibc-devel-2.22-17.fc23.x86_64) is already installed

 

O que fazer agora?

Compartilhar este post


Link para o post
Compartilhar em outros sites

O libva-intel-driver-1.6.2-1.fc23.i686.rpm   exige a bilbioteca glibc., mas pelo alerta acima a mesma já estaria instalada....e o steam exige o libva-intel.... ( ou seja, estamos em um labirinto sem saída)

 

Execute no terminal (como root):

 

dnf update "enter"

 

dnf upgrade --refresh "enter"

 

Ah., sempre esqueço de perguntar: porquê trocou o Manjaro pelo Fedora ?

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 horas atrás, Manjaro disse:

O libva-intel-driver-1.6.2-1.fc23.i686.rpm   exige a bilbioteca glibc., mas pelo alerta acima a mesma já estaria instalada....e o steam exige o libva-intel.... ( ou seja, estamos em um labirinto sem saída)

 

Execute no terminal (como root):

 

dnf update "enter"

 

dnf upgrade --refresh "enter"

 

Ah., sempre esqueço de perguntar: porquê trocou o Manjaro pelo Fedora ?

 

 

Eu acho que acabei detonando o meu manjaro por acidente )-: 

 

Tipo eu usava o manjaro com o gnome-shell eu meio que enjoei do ambiente grafico e acabei sendo atraido pelo Kde 5 então eu instalei o Kde 5 e logo depois removi o gnome-shell...

 

Porém depois disto atualizei o sistema e o manjaro atualizou o servidor grafico o X ok desliguei o sistema e fui dormir no dia seguinte o sistema não iniciava de modo algum(Nem mesmo tentando Init 1)...

 

Com o lançamento de outras distros eu acabei curioso então tentei de primeira o opensuse leap cara que arrependimento logo depois de instalar esse sistema eu não conseguia dar login o X dava crash antes... Então eu tentei o fedora e foi lindo com exceção deste problema no steam... 

 

Ahh e eu acho que descobri o problema...

 

O steam do Rpm-fusion e uma versão antiga para o fedora 22 e como eu estou usando o fedora 23 a coisa não funciona...

 

Citação

steam                                  i686                    1.0.0.50-2.fc22                                 @rpmfusion-nonfree                    2.6 M

 

Agora o esquisito e eu conseguir instalar uma versão antiga mas não conseguir instalar uma versão para o sistema atual...

 

Será que as dependencias são pacotes do fedora 22?

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, NETfellow disse:

Agora o esquisito e eu conseguir instalar uma versão antiga mas não conseguir instalar uma versão para o sistema atual...

 

Será que as dependencias são pacotes do fedora 22?

 Como eu "penso" só quem está frente a frente com o sistema consegue estancar a ferida ou pelo menos apresentar um suspeito para a causa do problema.

 Ainda não foi liberado o pacote steam para o fedora 23 ?

 * detalhe: em alguns sites ( cacique google) a informação é que o procedimento de instalação funcionaria na versão 22 e 23.

 

  Opensuse !? novamente reiterando "pensamento meu" -> já foi bom., mas pra mim não vale a pena

1 hora atrás, NETfellow disse:

eu acabei curioso então tentei de primeira o opensuse leap cara que arrependimento logo depois de instalar esse sistema eu não conseguia dar login o X dava crash

 O erro é a birra que o opensuse tem com chipset da Nvidia....( o sistema até carrega depois de alguns resets) mas tem que ser ligeiro na instalação do driver...

 Fedora !? novamente reiterando "pensamento meu" -> é um bom sistema., boa estabilidade.... mas gosto da alternativa chamada korora. O Korora está para o fedora como o Linux Mint está para o Ubuntu..

 

Ambientes!? não sou fã nem do Kde ( é um porre o tal de kwalletmanager) e nem do gnome ( apesar que o gnome vem evoluindo) então vou de cinnamon, xfce e mate. ambientes como lxqt, deepin e budgie, aguardo um melhor amadurecimento.

Compartilhar este post


Link para o post
Compartilhar em outros sites
17 horas atrás, Manjaro disse:

 Como eu "penso" só quem está frente a frente com o sistema consegue estancar a ferida ou pelo menos apresentar um suspeito para a causa do problema.

 Ainda não foi liberado o pacote steam para o fedora 23 ?

 * detalhe: em alguns sites ( cacique google) a informação é que o procedimento de instalação funcionaria na versão 22 e 23.

 

  Opensuse !? novamente reiterando "pensamento meu" -> já foi bom., mas pra mim não vale a pena

 O erro é a birra que o opensuse tem com chipset da Nvidia....( o sistema até carrega depois de alguns resets) mas tem que ser ligeiro na instalação do driver...

 Fedora !? novamente reiterando "pensamento meu" -> é um bom sistema., boa estabilidade.... mas gosto da alternativa chamada korora. O Korora está para o fedora como o Linux Mint está para o Ubuntu..

 

Ambientes!? não sou fã nem do Kde ( é um porre o tal de kwalletmanager) e nem do gnome ( apesar que o gnome vem evoluindo) então vou de cinnamon, xfce e mate. ambientes como lxqt, deepin e budgie, aguardo um melhor amadurecimento.

 

Sim o pacote do steam para o fedora 23 foi liberado porém quando tento instalar da em uma quebra de dependência:

 

Citação

Error: nothing provides libva-intel-driver(x86-32) needed by steam-1.0.0.52-2.fc23.i686
(tente adicionar '--allowerasing' a linha de comando para substituir pacotes conflitantes

 

O opensuse por algum motivo implica com a placa de video... O engraçado e que ele carrega o nouveau sem problemas... Eu conseguia ver a tela de login sem problemas porém o Kde não carregava de jeito nenhum...

 

O Kwalletmanager sumiu no Kde 5 pelo menos no fedora... Eu ate cheguei a usar o cinnamon no Linux mint mas ele travava muito ainda na epoca que eu ainda usava a Vga onboard... Os mais novos como o deepin e budgie ainda não testei...

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 minutos atrás, Manjaro disse:

@NETfellow - encontrou a solução para uso do steam no fedora., vai partir para outra distro ou vai desisitir do steam ? :aranha:

 

Não achei uma solução... )-:

 

Vou ficar no fedora o sistema e bem polido então vou ficar sem usar o Steam no computador por enquanto...

 

Obrigado por tudo @Manjaro (-: 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 12/06/2016 às 17:53, Manjaro disse:

@NETfellow - há informações do problema junto à comunidade do Fedora ( foruns, blogs, site oficial...) ???

 

Eu não achei nada )-:

 

Ps: Desculpa a demora tive problemas com a internet 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@NETfellow o jeito então é aguardar atualização dos repositórios

 

fui "desafiado" a instalar o antergos..... (_( ---- o problema estaria entre o teclado e a cadeira ??

 

Ok.... antergos instalado.... tudo certo.... só dá problema na instalação do wps office ( falha no dowload) kkkkkkkkkkkkkkkkkkkkkkkkkk...... o seu fedora com steam e o meu antergos com o wps office.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 14/06/2016 às 23:09, Manjaro disse:

@NETfellow o jeito então é aguardar atualização dos repositórios

 

fui "desafiado" a instalar o antergos..... (_( ---- o problema estaria entre o teclado e a cadeira ??

 

Ok.... antergos instalado.... tudo certo.... só dá problema na instalação do wps office ( falha no dowload) kkkkkkkkkkkkkkkkkkkkkkkkkk...... o seu fedora com steam e o meu antergos com o wps office.

 

kkkkkkk

 

Acontece com release do Fedora 24 minhas esperanças de instalar o steam e fazer a coisa toda funcionar reapareceu...

 

mas por que não usar o libreoffice?

Compartilhar este post


Link para o post
Compartilhar em outros sites
55 minutos atrás, NETfellow disse:

mas por que não usar o libreoffice?

 Eu utilizo o Libre Office., mas como gosto de coisas novas... resolvi experimentar o Wps office.. ( o mesmo havia sido tirado do ar) por isso o antergos não conseguia efetuar a instalação. Mas hoje a mesma foi concluída com êxito.

A compatibilidade do Wps Office com o Microsoft Office é melhor que a do Libreoffice.... 

 

e por falar em Fedora 24 & Steam., tente instalar o mesmo usando o Fedy:

 

https://www.edivaldobrito.com.br/ferramenta-pos-instalacao-fedy/

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×