Ir ao conteúdo
  • Cadastre-se
dhichagas

Algoritmo nó no juizo

Recommended Posts

 

Algoritmo Nó_no_juizo
 L1,L2,L3 : string
início
 	leia L1,L2,L3 {deve ser digitado apenas as letras V ou F}
 	se L1="V"
 		então
 	escreva "A"
 senão
 	se L2="V"
 		então
 			se L3="V"
 				então escreva "B"
 			fim-se
 	senão
 		escreva "C"
 		escreva "D"
 	fim-se
 fim-se
 escreva "E"
fim

Perdi o juízo fazendo teste de mesa nesse algoritmo alguem poderia me ajudar a resolver esses exercicios abaixo?

__________________________________________________________

 

1) Se forem lidos V, V e F, o que será escrito pelo algoritmo? RESP: ACDE
 2) Se forem lidos F, V e F, o que será escrito pelo algoritmo? RESP: CDE
3) Se forem lidos F, V e V, o que será escrito pelo algoritmo? RESP: BCDE
4) Que valores deveriam ser lidos para que fosse escrito apenas "E"? "Aqui eu não sei kkkkkkkkkkkk'"

Caso eu esteja errado nas respostas do numero 1 2 e 3 me ajudem :)
 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

dhichagas
   Pelo tipo do algoritmo suponho que você esteja usando o visuALG 3.
   Seu código está um pouco desorganizado e com alguns erros de sintaxe, então 
estou apenas organizando ele, e coloquei essas linhas aí no começo para melhor
orientação.  com isso basta digitar os valores para ver as respostas, e essas
respostas aí não estão certas não.  e essa palavra então tem que ser sem til.

Algoritmo "juizo"
// Disciplina   : [Linguagem e Lógica de Programação] 
// Professor    : Antonio Carlos Nicolodi 
// Descrição   : Aqui você descreve o que o programa faz! (função)
// Autor(a)    : Nome do(a) aluno(a)
// Data atual  : 10/6/2016
Var
// Seção de Declarações das variáveis 
L1,L2,L3 : caractere//string

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
//leia L1,L2,L3 {deve ser digitado apenas as letras V ou F}
escreva("Digite A Primeira Letra [ v ] ou [ f ] ")
leia(L1)
escreva("Digite A Segunda Letra [ v ] ou [ f ] ")
leia(L2)
escreva("Digite A Terceira Letra [ v ] ou [ f ] ")
leia(L3)
se L1="V" então
  escreva("A")
  senao
  se L2="V" então
    se L3="V" então
      escreva("B")
    fimse
    senao
      escreva("C")
      escreva("D")
  fimse
fimse
escreva("E")
Fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@dhichagas , o @devair1010 apenas corrigiu a sintaxe (fazer compilar corretamente). Você ainda precisa resolver a parte da lógica.. :)

 

1) Sobre sua dúvida

Em 10/06/2016 às 16:19, dhichagas disse:

Caso eu esteja errado nas respostas do numero 1 2 e 3 me ajudem :)

 

Creio que esteja errado. Com esse novo código, tente refazer os testes. Primeiro você faz uma simulação "de cabeça", acompanhando a lógica do código e anota. Após, executa e compara se deu o resultado esperado... por ai vai.

 

**

 

2) Sobre a leitura dos dados

Dá para solicitar a leitura dos 3 valores de uma vez só (separado por ENTER). Vide código abaixo.

 

3) Sobre a identação do se, pode ser feita assim também:

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
//leia L1,L2,L3 {deve ser digitado apenas as letras V ou F}
escreva("Digite as 3 letras [ V ] ou [ F ] ")
leia(L1,L2,L3)
se L1="V" então
   escreva("A")
senao
   se L2="V" então
     se L3="V" então
        escreva("B")
     fimSe
   senao
      escreva("C")
      escreva("D")
   fimSe
fimse
escreva("E")
FimAlgoritmo

**Basicamente deixei o senão alinhado com o seu respectivo se.

Veja, a identação é de suma importância. Ela NÃO INFLUENCIA NA EXECUÇÃO DO PROGRAMA, mas serve como referência para o programador! Só de olhar para o código, dá para ver como vai se comportar!!!

Ela deve sempre ser feita de acordo com o código, e não de acordo com o que você pretendia! (ou seja, se você identar, e ver que não está de acordo com o que deseja, você precisará corrigir o código.

Obs.: O ideal é já programar deixando identado!!!

 

No aguardo.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×