Ir ao conteúdo
  • Cadastre-se
aacayipsinjr

Dificuldade ao utilizar condição

Recommended Posts

Bom dia pessoal,

 

Estou fazendo uma planilha em meu trabalho da seguinte forma:

 

Pasta 1

 

1. Em L5 eu tenho =(SE(I5="APLICÁVEL";K5-HOJE();SE(I5="NÃO APLICÁVEL";"";SE(I5=0;"";SE(I5="APLICADA";"FINALIZADA"))))) - Trago a informação se em i5 encontro a opção de aplicação do meu mapeamento, sendo que, se "aplicável", o objetivo é mostrar uma contagem de dias (com esse -HOJE()) e se "não aplicável" mostrar nada "".

 

2. O resultado da primeira fórmula é cascateado em uma segunda: =SE(L5="FINALIZADA";"OK";SE(L5<0;"VENCIDA";SE(L5>1;"PROGRAMADA";SE(L5=0;"NA")))) 

Não tenho problemas ao mostrar o "OK" ou o "VENCIDA", mas com relação ao "PROGRAMADA", preciso que o excel busque o que seja maior que 0, porém, é contabilizado as células que estão em branco (que deveriam aparecer o FALSO, que na primeira fórmula coloquei para aparecer nada "").

 

Pergunta:

O que posso fazer para que o excel realmente considere os valores maiores que 0 ao invés de contar celulas com formula?

 

Pasta 2

Tenho em E uma relação com todos os treinamentos que apliquei, e tenho que contar a quantidade. Porém, preciso somente que o excel conte os valores únicos.

Nessa coluna tenho então vários nomes repetidos e células em branco.

 

Agradeço a quem puder ajudar.

Pasta1.xlsx

Pasta2.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde

 

Na Pasta 1, copie e cole a fórmula abaixo na célulaM5 e arraste até a célula M13:

=SE(L5="FINALIZADA";"OK";SE(L5<0;"VENCIDA";SE(L5<>"";"PROGRAMADA";"NA")))

 

Na Pasta 2, apliquei uma fórmula matricial, portanto, no final em vez de teclar ENTER, tecle CTRL+SHIFT+ENTER

Confira na planilha:

 

Se foi útil, clique em Curtir

 

Dê retorno.

 

[]s

 

06_07_16_Contar unicos-Patropi.zip

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi

Perfeito Patropi, muito obrigado.

 

Porém, no exemplo da pasta 2 que enviou tratada no anexo, só teve uma questão: a formula está funcionando, porém, quando trago ela para a minha base, tenho linhas em branco e a formula traz um erro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por isso, eu sempre falo, que o exemplo tem que ser o mais real possível, pois senão, como vamos fazer testes???

 

Se a minha resposta foi útil, porque você não clicou em curtir.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 minutos atrás, Patropi disse:

Por isso, eu sempre falo, que o exemplo tem que ser o mais real possível, pois senão, como vamos fazer testes???

 

Se a minha resposta foi útil, porque você não clicou em curtir.

 

[]s

Meu amigo,

 

1. No arquivo que mandei de exemplo existem inúmeras linhas em branco e na mensagem que enviei têm a informação "Nessa coluna tenho então vários nomes repetidos e células em branco".

2. Sua resposta sim foi útil, além de agradecer em minha resposta, cliquei em curtir.

 

PS: agradeço novamente a ajuda, mas não entendi sua réplica que soou um tanto quanto presunçosa.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pela tua descrição, eu entendi que seriam linhas em branco entre uma linha e outra, o que não consta no teu exemplo, por isso eu solicitei outro exemplo, pois cada caso é um caso.

Mas já que me considera assim, vou deixar que outra pessoa continue te ajudando.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×