Ir ao conteúdo
  • Cadastre-se
Luiz Vilaça

Exercicios visualg usando laços de repetição

Recommended Posts

Fala galera, se alguem puder me ajudar, estou com um probleminha pra resolver rápido...

 

Escreva um algoritmo que receba dois números inteiros quaisquer, exemplo A e B. Se A for menor que B, apresente na tela todos os números divisíveis por 3 dentro desse intervalo.

 

   4.1 Um usando o comando repita... ate


 

    4.2 Um usando o comando enquanto ... faca ... fimenquanto


 

     4.3 Um usando o comando para..

 

Com o comando repita foi tranquilo,mas o restante complica um pouco. Agradeço a ajuda de quem puder..

Grato,

Luiz Vilaça

Editado por dif
Melhorar o título

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a sua resposta está certa ou não, ou para que possamos ajudá-lo com a sua dúvida no desenvolvimento do exercício.

 

Infelizmente, não temos como resolver seus trabalhos por você. O objetivo do Fórum do Clube do Hardware é auxiliar você a sanar suas dúvidas, e não de responde-las em seu lugar. Além disso, copiar e colar respostas que não são de sua autoria é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luiz Vilaça O algorítimo é quase o mesmo para os restantes testes lógicos. Poderia nos passar o exercício feito no comando "repita até"?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Usei uma base de uma apostila, mas depois de alguns teste, não obtive o resultado esperado. 

Var
A,B:real

Inicio
escreva ("Valor de A: ")
leia (A)
escreva ("Valor de B: ")
leia (B)
se A<B  então
repita
escreva (A)
A<-A+3
ate A>B
fimse
fimalgoritmo

 

 

porém não me dá os numeros divididos por 3, e sim numeros somados a 3..

se puder me salvar nessa ai, agradeço..

 

Editado por dif
Inserir o código usando o botão CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Luiz Vilaça,

 

Você precisa desenvolver/encontrar uma forma para descobrir se um número é múltiplo de outro ou não.

 

Uma forma bem popular é "dividir um número pelo outro e verificar se tem resto"...  após, implementar no contexto do seu algoritmo.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×