Ir ao conteúdo
  • Cadastre-se
Davi Ferreira

Consolidar saldos de um dia em outra planilha

Recommended Posts

Galera, boa noite!

Postei recentemente aqui uma dúvida sobre macros e consegui a resolução, alinhei o mesmo as minhas necessidades e está perfeito.

 

Porém, resolvi apromorar minha planilha e agora estava precisando de algo simples, porém eficaz para mim no momento:

O que ocorre é o seguinte:

Minha planilha transfere os lançamentos para um BD e dele eu gostaria de transferir os lancaçentos do dia para outra aba, neste caso o livro caixa da empresa.

Na prática:

Digamos que no dia eu efetuei 10 lançamentos, eu gostaria que a macro procurasse os lançamentos do dia de hoje e transferisse para a aba do livro caixa, colocando as entradas na coluna das entradas e as saídas nas saídas.

 

Em anexo segue a planilha para vocês observarem melhor, vejam que eu quero que os itens da aba lançamentos para a aba LV Caixa.

 

 

P.s. Na planilha eu deixei 3 lançamentos, 2 de entrada e 1 de saída só para servir de exemplo para vocês trabalharem a transferência do saldo.

P.s2. Não precisa criar a macro e enviar pronta dentro da plan, estou voltando a trabalhar com excel e prefiro eu mesmo colocar dentro do botão para voltar a me acostumar, apenas analisem a situação, vejam se podem me ajudar e enviem a macro, eu me viro!

 

 

Galera, desde já agradeço e caso não possam me ajudar, agradeço mesmo assim!

 

esboço fama jr contabilidade - Copia.rar

Compartilhar este post


Link para o post
Compartilhar em outros sites

Que informações deseja copiar?Nao entendi muita coisa você quer obter so os totais, ou seja, Data total de entradas e total de saidas.. ou todos os lançamentos se for a segunda opção a planilha lançamento nao faz sentido nem é necessaria

 

Preenche a planilha LV Caixa com os dados que você quer copiar e de onde vai vir os dados,

 

Da Plan1 ou da Lançamentos?

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 horas atrás, Davi Ferreira disse:

... transferir os lancaçentos do dia para outra aba...

O que é lancaçentos ? É bicho mais perigoso do que político brasileiro ? :atirador::P

 

... eu gostaria que a macro procurasse os lançamentos do dia de hoje ...

Você sempre irá acionar a macro no mesmo dia dos lançamentos?

Após replicar os lançamentos na plan 'LV CAIXA' você quer limpar a plan "Lançamentos" ?

Na plan 'LV CAIXA' você desenhou uma tabela e nela reservou somente 48 linhas para os lançamentos. Em 'L4' daquela plan consta que a tabela seria para todo o ano de 2016. É isso mesmo, 48 linhas seriam suficientes para os lançamentos até o final do ano ?

 

P.s. Na planilha eu deixei 3 lançamentos, 2 de entrada e 1 de saída

Em que coluna podemos obter a informação se o lançamento é uma "entrada" ou uma "saída" ?

Se for na coluna 'H' lá consta 'saída' para os 3 lançamentos :(

A propósito, as suas fórmulas da coluna 'H' sempre retornarão "saída" pois o intervalo de busca do PROCV não está correto ;)

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@osvaldomp Então Osvaldo, corrigi os erros e está aí o que preciso

1- Dos 3 lançamentos que estão no exemplo, preciso que eles sejam transferidos para a LV caixa apenas as colunas:

G(Data)

F(histórico)

E(valor)

 

esses 3 campos irão para as colunas correspondetes na plan "LV Caixa", sendo que o Valor

se for entrada, vá para a coluna entrada

se for saída, vá para a saída.

 

E sim, a macro será executada no dia que for efetuado o lançamento, exemplo

 

Caso eu realize lançamentos 10 lançamentos hoje, ao usar a macro os 10 irão para o lv caixa na ordem de entradas e saídas.

 

 

Sobre a quantidade de linhas, não se preocupe, se precisar eu adicionarei mais ;)

P.S. Obrigado pela observação quanto ao procv, não sei de onde tirei o "6" alí.

P.s.2: Não precisa limpar os registros da aba "lançamento" após copiar os dados para a aba do LV caixa

Abraços.

esboço fama jr contabilidade.rar

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Davi Ferreira Olá, Davi. Veja se o código abaixo atende. Coloque na planilha "Lançamentos" o botão para rodar o código.

Sub ReplicaLançamentos()
 Dim LR As Long, c As Range
  Application.ScreenUpdating = False
  On Error Resume Next
  ActiveSheet.ShowAllData
  [A1].AutoFilter Field:=7, Criteria1:=xlFilterToday, Operator:=xlFilterDynamic
  With Sheets("LV CAIXA")
   If .[B10] = "" Then LR = 9 Else LR = .[B9].End(4).Row
   For Each c In Range("E2:E" & Range("E" & Rows.Count).End(3).Row).SpecialCells(xlVisible)
    If c.Offset(, 3).Value = "saída" Then .Cells(LR + 1, 10) = c.Value Else .Cells(LR + 1, 8) = c.Value
    .Cells(LR + 1, 2) = c.Offset(, 2).Value: .Cells(LR + 1, 4) = c.Offset(, 1).Value: LR = LR + 1
   Next c
  End With
  ActiveSheet.ShowAllData
  Application.ScreenUpdating = True
End Sub

 

Dicas aproveitando as tabelas que você construiu na planilha "bd":

1. a fórmula que existe na coluna 'H' da planilha "Lançamentos" (esta abaixo)

=SE(A2="";"";(SE(OU(PROCV(Lançamentos!A2;$A$1:$G$1475;2;0)="ativo";PROCV(Lançamentos!A2;$A$1:G$1475;2;0)="receita");"Entrada";"saída")))

pode ser substituída por esta =SE(A2="";"";PROCV(A2;bd!$B$1:$D$18;3;0))

2. para evitar erros de digitação, o que provocará erro nas fórmulas, e também para agilizar o preenchimento do lançamento, aplique Validação de Dados na coluna 'A' da planilha "Lançamentos"

3. me parece que caberia um PROCV também nas colunas 'B:D' da planilha "Lançamentos"

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×