Ir ao conteúdo
  • Cadastre-se
Clawber Santos

Problemas com o uso variáveis em c pic16f877a

Recommended Posts

Oi sou iniciante com programação em c para microcontroladores e estou tendo dificuldades com o uso de variáveis, segue meu código, se alguém puder indicar meu erro,desde já agradeço.

#include <lab01.h>
#use   delay(clock=20000000)
#fuses hs,put
#use fast_io(a)
#use fast_io(b)
#use fast_io(c)
#use fast_io(d)
#use fast_io(e)
#byte porta = 0x05
#byte portb = 0x06
#byte portc = 0x07
#byte portd = 0x08
#byte porte = 0x09
#bit nivel1 = portd.0
#bit nivel2 = portd.1
#bit led1 = portc.0
#bit led2 = portc.1
void main()
{
unsigned char x = 0;
set_tris_c(0b00000000);
set_tris_d(0b11111111);
while(true)
{
if(nivel1==0)
led1=0;
if(nivel1==1)
{led1=1;
x=x++;
}
if(x==10)
led2=1;
}}

Uso um pic16F877A em uma placa didática da cuscopic. A parte do código que nao usa variáveis funciona perfeitamente mas após o uso das variáveis é como o pic nao as reconhecesse.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

realmente você precisa definir as variáveis antes.  Algo como

unsigned char x;

A dica que dou é: abra um exemplo que vem com o compilador e sua mente se abrirá junto.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×