Ir ao conteúdo
  • Cadastre-se
Goriebir

Excel - reconhecer número no formato "0000.00.00"

Posts recomendados

Bom dia pessoal

Estou com uma dúvida aqui que não consigo resolver tenho vários produtos que são classificados de várias maneiras, uma delas é pelo NCM. Esses números são do formato 0000.00.00. Então por exemplo eu quero fazer uma funcão Se para fazer um tipo de cálculo de acordo com o NCM. Os números de meu interesse são: (7320.20.90 e 8302.50.00), ou seja, quando o produto apresentar esse NCM eu quero fazer um cálculo específico. Eu tentei usar essa funções sem sucesso.

1- =SE(A1="7320.20.90"; A1*1,302;A1)

1- =SE(A1=7320.20.90; A1*1,302;A1)
 

Já tentei colocar a célula A1 como texto, como número, como geral mas todas as fórmulas deram erro. Como faço para o excel "reconhecer" esse número nesse formato (0000.00.00)??

Agradeço muito a contribuição da comunidade

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tardeGoriebir

 

Seja bem -vindo ao fórum!

 

Numa outra coluna copie e cole a fórmula abaixo e arraste até a linha desejada.

=SUBSTITUIR(A1;".";"")

 

Depois use a tua formula assim, ajuste a coluna, pois eu considerei como coluna B.

=SE(B1=73202090; B1*1,302;B1)

 

Se foi útil, clique em Curtir.

 

Dê retorno.

 

[]s

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Goriebir Bom dia.

 

Usando a formula que o colega @Patropi fez, pode usar esta em uma unica formula e obtêm o resultado

 

=SE(VALOR(SUBSTITUIR(A1;".";""))=73202090; VALOR(SUBSTITUIR(A1;".";""))*1,302;A1)

 

Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi e @deciog. Realmente funcionou, muito obrigado. Pelo que entendi a função substituir ela "retira" os pontos e rescreve o número sem eles né.

Eu adicionei a função ou então eu consigo usar a mesma lógica e expandir para mais números, mas até agora não entendi por que o excel não reconheceu o número naquele formato. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Goriebir

 

Se a célula que esta o numero com os pontos, então ela é texto, agora se a célula estive com numero porém formatada com o pontos, então é numero, a multiplicação só pode ser em numero, por isso a substituição tirando o ponto, para fazer o calculo.

 

Espero ter ajudado

 

Décio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Goriebir

 

O Excel do Brasil, reconhece a virgula como separador de casas decimais.

O ponto é utilizado pelo Excel em Inglês, por isso, dá esse problema.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

este NCM deve ser tratado como texto.

insira aspas simples ao incluir o numero que o excel entende que aquela célula é texto.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Goriebir Consegui usando a seguinte formula.

 

Exemplo Tenho o texto 12345678 na coluna A1, quero deixar ele assim 1234.56.78

 

Faremos o seguinte, =TEXTO(A1;"000\.00\.00")

 

Não me pergunte o porque, mas funciona o texto ficará 000.00.00.

 

:D  

 

Usei isso pra minha macro de inserir nota fiscal no SAP de forma automatizada.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Este tópico está parado há muito tempo. Certifique-se que a sua mensagem tem a ver com o tema sendo discutido. Obrigado.

Junte-se à conversa

Você pode postar agora e cadastrar-se depois. Se você tem uma conta, faça o login para postar.

Visitante
Responder

×   Você colou conteúdo com formatação.   Restore formatting

  Só é possível ter até 75 emoticons.

×   O link foi automaticamente convertido para mostrar o conteúdo.   Clique aqui para mostrá-lo como link comum

×   Seu texto anterior foi restaurado.   Limpar o editor

×   You cannot paste images directly. Upload or insert images from URL.






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!