Ir ao conteúdo
  • Cadastre-se
aphawk

Apple ii na mina de ouro

Recommended Posts

Vou contar aqui um caso que ocorreu comigo, não tem muita coisa a ver com o tópico, mas como eu utilizava um Apple ][ naquela época para fazer a automação de um monte de fábricas, resolvi contar o que aconteceu em uma grande mineradora de ouro, no interior de Minas Gerais.

 

Mais uma vez, no final veremos o famoso "CUSTO BRASIL" em ação, o qual infelizmente nos persegue até hoje !

 

Tivemos um pedido de uma mineradora de ouro em Minas Gerais : produzir um equipamento monitor para cuidar de um compressor de oxigênio puro.

 

Mas não era um simples "compressor" :

 

Em uma mina de ouro dentro da montanha, o oxigênio tem de ser produzido na superfície E bombeado por grandes distâncias para o subsolo.

 

A produção é feita por uma usina, uma verdadeira fábrica de vários gases, e esse oxigênio é produzido e deve ser armazenado no formato líquido, e quem faz a transformação de ar para líquido é um compressor, com um motor de 6 cilindros enormes, o qual vai trabalhar com esse oxigênio líquido puro, que é totalmente inflamável !

 

Esse compressor ficava em uma base de concreto, no canto da usina, e media aproximadamente 6 metros de comprimento, 2 metros de largura, e 2 metros de altura. Praticamente tudo feito de aço.

 

Enquanto esse compressor não funcionar, todo o oxigênio produzido não pode ser armazenado e é lançado novamente à atmosfera.

 

Esse compressor possuía 48 termopares, que são sensores de temperatura, os quais são instalados em pontos chaves , sendo 4 termopares em cada cilindro, e outros em vários locais chaves para o funcionamento.

 

Nosso equipamento tinha de ter 48 Leds mostradores, e algumas saídas as quais forneciam ao computador central da usina informações sobre alguma irregularidade medida no compressor. Essas saídas eram 8 saídas digitais, tipo contato seco.

 

O mais curioso eram a maneira que o nosso aparelho tinha de monitorar e indicar... existiam cerca de 8 fórmulas matemáticas, algumas envolvendo mais de um cilindro, outras envolvendo outros sensores, e a cada 5 segundos eram feitos leituras e cálculos, os quais causavam o acendimento dos Leds conforme a situação a ser indicada, e ao final causavam a sinalização das 8 saídas digitais.

 

Nossa empresa possuía um hardware padrão Z-80, o qual era composto por alguns módulos, tipo placa CPU , placa de I/O , placa de backup de baterias, etc.

 

A nossa placa de ligação de termopares não atendia tantos termopares, então tivemos de projetar uma nova, a qual deu bastante trabalho, e foi desenvolvida em função do tipo específico de termopar, que eram especiais, pois eram do tipo totalmente isolados da carcaça, bem compridos, e que suportavam a enorme vibração do motor. Resultou em 3 placas que podiam aceitar 16 termopares cada uma.

 

Nosso equipamento de desenvolvimento era baseado em Apple ][, usando CPM/80, e uma placa gravadora de Eprom, pois naquele tempo usávamos Eproms de 2Kx8 , e nesse projeto usamos 4 Eproms 2716 se não me engano.


Os programas mais utilizados eram o M80, que era um macro-assembler para Z80, e o L80, que era o linker. Ah, o programa era escrito com o WORDSTAR-80. Tudo isso rodava em CPM, a partir de duas unidades de disquetes.

 

Após 5 meses, nosso produto estava pronto. A empresa contratante havia enviado todas as informações do termopar que seria usado nesse compressor, e todo o nosso hardware de entrada analógica foi feito baseado nele.

 

Cada termopar desse custava US$ 1400 naquela época.

 

Para entenderem o tamanho da operação dessa mina de ouro : enquanto o compressor não entrava em funcionamento, todo dia chegavam 6 caminhões grandes com oxigênio líquido para abastecer essa mina de ouro. O custo disso era muito maior do que se fosse produzido no local.

 

Finalmente, enviamos o equipamento para o cliente, o qual demoraria cerca de uma semana para homologar o aparelho.

 

Mas, para nossa surpresa, logo no primeiro teste, o aparelho falhou, mostrando "mais luz do que uma árvore de Natal" , e sinalizando um monte de problemas no compressor, então o teste do compressor durou menos do que 5 minutos e foi desligado.

 

Aí que começou o meu sofrimento : fomos mandados para Minas Gerais, eu e o outro engenheiro responsável pelo projeto, e levamos o nosso equipamento de desenvolvimento completo, bem como hardware adicional para fazer a troca eventual de placas e / conserto do que fosse necessário.

 

Chegando ao local, arrumaram uma pequena salinha para ficarmos, onde mal conseguimos alocar o Apple e o gravador de Eprom, imaginem ainda desmontar o equipamento monitor e fazer a sua manutenção....

 

Bom, logo de cara notamos que várias entradas analógicas estavam queimadas. Fizemos a substituição dos componentes, deixamos tudo funcionando novamente. Fomos pegar na Central as informações que ocorreram no teste, pois eles tinham um gravador de eventos, o qual marcou ao longo do tempo toda a informação que foi enviada pelo nosso monitor ao computador central.

 

Não fazia sentido...  parecia que ocorreram várias situações de temperaturas que não estavam previstas. Não batiam com as informações do fabricante do compressor. Então, pensamos que tínhamos dois problemas separados :

 

1 - Falha no hardware de interface aos termopares, pois várias entradas foram danificadas.
2 - Falha no programa do controlador.

 

Então, partimos para resolver. Trabalhávamos das 8 da manhã até cerca de 6 horas da noite, e após isso saímos da empresa de mineração para uma cidadezinha bem pequena que havia a menos de 2 KM dali, onde ficamos em um hotelzinho.

 

Na entrada e na saída, o carro era totalmente revistado, e nós também éramos revistados. Tudo para que não levassem nenhuma pedra de ouro embora do local....

 

Comecei a consertar a placa de entrada. Alguma coisa devia ter acontecido nas entradas, algum curto-circuito, alguma ligação errada, algum loop de terra, pois as entradas tinham todas elas diodos de proteção, e as tensões a serem geradas eram da ordem de milivolts, nunca deveriam danificar os circuitos. Mas, curiosamente, haviam vários diodos em aberto !

 

Comecei a medir cuidadosamente os cabos que eram conectados à essas entradas. Não achei nada de errado, não haviam curtos, os sinais estavam isolados do terra conforme exigia a especificação.

 

Na parte do programa de nosso aparelho, não encontramos nada de errado. Mas por precaução, bolamos algumas novas rotinas, e criamos uma nova sinalização que faria alguns Leds piscarem, que era uma indicação para nós que estavam ocorrendo situações de entrada não previstas. Claro que essas rotinas seriam removidas após normalizarmos a situação.

 

Então, após tudo isso, marcaram um novo teste do compressor, seria feito num domingo, na parte da tarde. E iríamos acompanhar na sala do computador principal !

 

Então, chegado o momento, com mais de 20 engenheiros e técnicos na sala, o compressor foi ligado. Era uma coisa impressionante, a nossa sala central sentia a vibração do motor, o qual gerava um baita dum barulho.

 

Eu praticamente não tirava os olhos do painel de nosso monitor. Após 2 minutos, as luzes começaram a acender, indicando algumas situações anormais.

E logo outras começaram a piscar, indicando que estávamos recebendo sinais na entrada que não foram previstos.


Logo, nosso equipamento realmente pareceu uma árvore de natal, e finalmente foram enviados os sinais para o computador central desligar o compressor, pois havia risco de incêndio do oxigênio líquido.

 

Imaginem como ficou a nossa cara, com todos olhando o nosso equipamento, e perguntando se era possível que houvesse algum defeito nele.....

Retiramos o equipamento , levamos ao laboratório, e comecei a verificar. Novamente algumas entradas foram danificadas, mas não eram as mesmas da vez anterior .....  então fiquei pensando o que que estava acontecendo... e não achava resposta !

 

Pedi para ir novamente à sala principal, pois queria medir os sinais que vinham dos termopares, e recebemos um NÃO como resposta, pois estavam fazendo um procedimento de verificação de toda a instrumentação, e fomos informados que só poderíamos ter acesso após 2 dias, e isso era uma norma.

 

Ficamos malucos procurando falhas tanto no hardware como no software. Mas não encontramos. Começamos a trabalhar até quase meia noite .....

 

Passados os dois dias, fui medir os sinais dos termopares, apostando que ocorreram alguns curto-circuitos entre o terra e um dos sinais dos termopares, pois apenas isso poderia explicar o que acontecia. Mas, não achei nada !!!!

 

Tudo estava de acordo com o correto. Não haviam nenhum sinal em curto, nenhum loop de terra, nada !

 

Mais uma vez ficamos doidos. Resolvi montar uma placa de amostragem, baseada em relés, que pegava apenas uma entrada de cada vez ( 3 sinais ) , e enviava ao nosso circuito de entrada padrão de termopar, que já havíamos usado outras vezes em outros projetos. Como o tempo de amostragem e de processamento era de 5 segundos, daria tempo para acionar um relé, selecionando um dos termopares, fazer a leitura, e partir para o próximo, e assim todos em sequência. Era a minha garantia de isolar um termopar de cada vez.

 

Projetamos a placa, e corri até Belo Horizonte para comprar todo o material. Após dois dias, tinha uma placa funcionando. Fiz os testes, e parecia que iria dar certo.

 

Marcamos mais um teste do compressor. Esta vez teríamos duas placas de entrada original, e uma placa nova, que era essa que utilizava os relés. Na minha teoria, essa nova placa não poderia sofrer nenhuma interferência de sinal, pois em cada instante apenas um dos termopares estaria ligado ao circuito de conversão.

 

No dia do teste, esta vez já com alguns "pistolões" da mineradora, mais uma vez ocorreram os mesmos problemas, inclusive nos termopares que estavam ligados nessa nova plaquinha que havia feito. Comecei a pensar que não iria conseguir resolver esse problema.

 

Quando levamos o aparelho ao nosso laboratório, notamos que a entrada analógica dessa minha nova placa estava em curto !!!! como era possível, se os relés só permitiam UM ÚNICO TERMOPAR DE CADA VEZ ?

 

Procuramos o engenheiro chefe, e disse que precisava olhar novamente os sinais que vinham dos termopares, pois tinha certeza de que havia algum erro em um daqueles 8 termopares. E mais uma vez fomos informados que só poderíamos medir após 2 dias !!!!!

 

Bom, já que não conseguia medir os sinais que iam até a sala principal, pensei comigo : posso ir direto no compressor, à noite, desmonto um dos termopares, e meço os sinais diretamente nele.

 

Esperamos até anoitecer, e para nossa sorte, veio uma baita neblina, que encobria tudo. Eram quase 9 horas da noite quando saímos e fomos ao compressor, levando ferramentas para desmontar, bem como duas lanternas, e desmontei o primeiro termopar cujo sinal havia danificado uma das entradas. E logo o multímetro me mostrou que havia um curto-circuito entre a carcaça e um dos sinais !!!!! Desmontamos então 8 termopares , retiramos todos eles, e levamos à nossa sala.

 

Logo de cara, meu amigo notou as letras com o código do termopar, e adivinhem .... NÃO ERA O MODELO QUE ENVIARAM PARA A GENTE !

 

Dois 8 termopares, dois estavam com defeito, sendo que um era o terminal positivo que ficou em curto, e o outro era o terminal negativo. Isso produzia loops, e apareciam sinais induzidos em nosso equipamento, alguns com nível suficiente para danificar os nossos circuitos.

 

Voltamos ao compressor, e cuidadosamente recolocamos os 8 termopares. E imaginei o que estava acontecendo : alguém lá sabia o que estava ocorrendo e estavam encobrindo, trocando os termopares !

 

Na parte da manhã, liguei para nossa matriz em SP, e passei o que havíamos descoberto, e pediram para que ficássemos em sigilo, não comentar nada, que eles iam verificar que raio de termopar eram esses que achamos no compressor.

 

Na parte da tarde, chegou a resposta. Eram termopares que eram compatíveis eletricamente, mas não na parte mecânica. Não foram feitos para aguentar vibrações de grande amplitude, as quais ocorriam em nosso compressor.

 

E a melhor parte : custavam cada um cerca de US$ 230 .... quase 6 vezes menos !!!!

 

Então, montamos uma operação de guerra. Logo imaginamos que durante esses dois dias iriam trocar os termopares por novos, senão eu iria achar o problema quando medisse os sinais na sala principal. Alguém estava encobrindo isso.

 

Ficamos sempre um de nós olhando de vez em quando o compressor, indo até o local a cada meia hora, e logo vimos alguns técnicos mexendo no compressor. Quando tentamos ir falar com eles, fomos impedidos, e nos informaram que era muito perigoso ir ao compressor quando estavam fazendo a verificação. Perguntei o que que eles faziam exatamente, e eles informaram que faziam até uma desmontagem de algumas partes, procurando algum problema, e remontando depois.

 

Agora, já tínhamos a certeza do que estava ocorrendo. Trocavam os termopares danificados !

 

Retirei a minha placa de amostragem, recoloquei a placa original, consertei as outras duas placas, e remarcamos um teste, onde pedimos a presença do engenheiro chefe responsável pelo projeto.

 

No dia marcado, o Engenheiro responsável pelo projeto  veio, perguntou o motivo de eu ter solicitado a presença dele, e eu pedi para que ele aguardasse o término do teste.

 

Mais uma vez, o compressor foi ligado, e novamente, tudo deu errado. Quando desligou o compressor, pedimos para que ele nos acompanhasse até a nossa sala, e explicamos o que estava acontecendo.

 

O cara quase teve um infarte. Perguntou se eu poderia provar, e eu disse que só poderia provar se tivesse acesso aos termopares no compressor antes que fossem trocados novamente.

 

Aí o cara lembrou de um fato estranho: ele havia aprovado um pedido de urgência de compra de mais um conjunto de termopares para esse compressor, mas como eram produzidos na Alemanha eles ainda não haviam chegado ! O departamento de compras fez a solicitação no mesmo dia em que houve a falha no primeiro teste ! Ele estranhou pois na compra original foram comprados 8 unidades adicionais para possível manutenção.

 

Então, começou o pega - prá - capar : O cara subiu conosco para a sala de controle, e pediu que um técnico nos acompanhasse até o compressor, levando as ferramentas para remover o termopar. E logo surgiram várias objeções, pois isso não poderia ser feito naquele momento, por motivos de segurança, pois o compressor ainda tinha partes quentes. Começou uma discussão.....

 

O cara não se fez de rogado : disse que já iria descer e ficaria no local do compressor, aguardando que o compressor esfriasse ! E lá fomos nós !

 

Cerca de duas horas depois, o próprio cara assumiu a responsabilidade, desmontou e retirou o termopar, e ele mesmo viu que o termopar não era o mesmo modelo que foi

especificado pelo fabricante ! Era o mesmo que eu havia anotado !

 

Eu já havia recebido por fax a especificação real, e mostrei para ele. Quando ele leu, ficou branco, nos pediu desculpas por tudo o que estava acontecendo, e subimos novamente para a sala de controle.

 

Chamou o engenheiro chefe responsável pela montagem, e deu uma baita comida de rabo, fez mil perguntas, aí começaram as ligações, e cerca de duas horas depois, a culpa caiu no departamento de compras, que havia justificado a compra dizendo que o fabricante alemão iria demorar muito para entregar, então compraram um equivalente americano, o qual custava exatamente o mesmo preço na planilha de compras. Mas o nosso fax mostrava o preço real, sendo muito inferior !

 

Tava na cara que alguém levou um bom dinheiro nessa jogada comercial ....

 

Bom, finalmente todos nos pediram desculpas, concordaram em pagar todas as nossas despesas, inclusive com as horas extras, e pudemos voltar para São Paulo no dia seguinte.

 

Os novos termopares chegaram quase um mês depois disso, e realizaram um novo teste.

 

Olhem como as coisas acontecem ..... :

 

Nesse novo teste, o programador responsável pelo computador principal "se esqueceu" de colocar o computador novamente no modo normal de trabalho, que é monitoração,  deixando ele no modo de programação.

 

Disseram para nós que no teste já haviam passados mais de 40 minutos sem nenhum problema, quando um dos Leds do nosso equipamento acendeu, sinalizando uma temperatura excessiva em uma daquelas contas que eram feitas, envolvendo a saída do oxigênio líquido. Como envolvia a saída do oxigênio, e não alguma coisa interna tipo cilindros, não era algo grave.

 

Passados alguns minutos, outros Leds começaram a acender, mas como o computador principal não estava acusando nenhum problema em nossas 8 saídas, imaginaram que era um problema em nossa sinalização apenas, e continuaram o teste.

 

Cerca de 5 minutos depois, houve uma explosão dentro do compressor, o oxigênio puro pegou fogo, e simplesmente derreteu o compressor, deixando um monte de material fundido !

 

O nosso equipamento havia acionado várias saídas para o computador principal, mas como ele não estava monitorando, nada aconteceu !

 

Resultado final : o compressor foi destruído, com um prejuízo de mais de 2 milhões de dólares, fora o tempo envolvido na compra e transporte de um novo compressor.

 

Se não fosse o registrador de eventos, nunca iam saber que o programador havia esquecido o computador no modo de programação. Várias pessoas foram despedidas, inclusive na parte de compras.

 

Eu sempre suspeitei que haviam mais problemas escondidos nesse projeto, e que resolveram destruir as provas.

 

Enfim, essa é mais uma história do Custo Brasil.

 

Paulo
 

  • Curtir 11

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nossa, que história muito louca. Aliás, parabéns por ter participado em tal projeto.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

A historia e legal, mas me traz lembranças sombrias, como uma vez que sabotaram uma rede em um local que eu nao posso falar em hipotese alguma (ligado a uniao) com um alfinete no cabo coaxial de rede, cortado e inserido de forma que era impossivel detectar sua presença...a nao ser com um TDR...

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@aphawk , é um absurdo uma situacao destas. Nao só a roubalheira, mas o pontecial para perda de vidas humanas. Isto nao é coisa de Custo Brasil. Isto é falta de carater das pessoas.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

que historia incrível !!!

fiquei imaginando toda a historia, como se fosse um conto de suspense ...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×