Ir ao conteúdo
  • Cadastre-se
BRUNOGTS2011

Arduino, ruído no cristal oscilador ao encostar o dedo no mesmo e travamento da

Recommended Posts

Fiz uma placa de circuito impresso com o microcontrolador usado no arduino (Atmega328p), porém achei um problema e não estou conseguindo resolver, toda vez que se encosta o dedo no cristal oscilador de 16MHZ o chip se perder e trava tudo e é necessário um reset, já coloquei um resistor de 1M ohm conforme placa original da arduino porém não resolveu nada, vocês teriam ideia de alguma proteção ou algo do gênero para que não ocorra mais este problema?

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, aphawk disse:

@BRUNOGTS2011 ,

 

Se voce usou um cristal comum, tem de usar os dois capacitares recomendados também...

 

Paulo

Eu usei dois capacitores de 22pf, ligado ao cristal e ao terra, mesmo assim da esse ruído.

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Ricardo S Ferreira disse:

Aterre o encapsulamento do cristal.

CARA É ISSO MESMO!

Bom, pra falar que não foi só isso, descobrimos que o grande problema também era a fonte de alimentação (aquelas meia boca que acho que nem tem transformador), pois foi só a gente troca-la que praticamente parou o ruído e mais, o aterramento elimina totalmente este problema! Muito Obrigado! haha

Compartilhar este post


Link para o post
Compartilhar em outros sites

que bom que resolveu. No entanto já vi circuitos microcontrolados funcionarem sem aterrar o cristal e até mesmo com fonte sem transformador. Quase com 100% de certeza você tem um na sua casa na máquina de lavar ou geladeira (apesar de não ser arduíno).

Um layout otimizado pode minimizar ainda mais os nocivos ruídos advindos do ... digamos .... além....

Mas se seu brinquedo(*) funcionou.. ótimo

(*) sem querer menosprezar hein!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Isadora Ferraz disse:

publique o esquema e layout

Vou fazer um teste quando chegar em casa diretamente com a placa original do arduino e ver se dá este ruído, acredito que não dê, entretanto a unica coisa que vi de incomum que eu não imagina no layout "oficial" era o Resistor de 1M ohm em paralelo com o cristal.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 31/08/2016 às 16:28, Isadora Ferraz disse:

que bom que resolveu. No entanto já vi circuitos microcontrolados funcionarem sem aterrar o cristal e até mesmo com fonte sem transformador. Quase com 100% de certeza você tem um na sua casa na máquina de lavar ou geladeira (apesar de não ser arduíno).

Um layout otimizado pode minimizar ainda mais os nocivos ruídos advindos do ... digamos .... além....

Mas se seu brinquedo(*) funcionou.. ótimo

(*) sem querer menosprezar hein!

Na verdade não, o aterramento só funcionou com uma fonte que eliminou totalmente os ruídos e até o momento só encontrei uma que não dê essas interferência, mas, para o caso do cristal eu consegui desenvolver uma solução, eis a seguinte:

Soldei um jumper em cima do cristal oscilador, este jumper conectei ao negativo de um capacitor eletrolitico, o positivo do capacitor conectei aos 5v e um led em paralelo ao capacitor para gastar a energia do capacitor, isto funcionou muito bem e agora eu posso colocar o dedo o quanto quiser no cristal que o microcontrolador atmega328p vai continuar funcionando normalmente! MAS...

Ao coloca-lo devolta no painel aqui da empresa para fazer sua função ele continua com o mesmo problema, não com o do cristal, mas o ruido da fonte e com um certo tempo de funcionamento o microcontrolador fica louco e para (não dura uns 20s).

Está difícil essa solução, no VI do regulador 7805 eu coloquei um capacitor de 47uF, no vou também + outro cerâmico de 100pf, não sei mais o que fazer para tirar o ruído disso, realmente tem uma solução? ou devo "abandonar" o arduino?

adicionado 1 minuto depois
Em 31/08/2016 às 15:02, Ricardo S Ferreira disse:

Aterre o encapsulamento do cristal.

Não funcionou completamente, agora o maior problema é o ruido da fonte.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 31/08/2016 às 16:28, Isadora Ferraz disse:

layout otimizado pode minimizar ainda mais os nocivos ruídos

Suspeitei desde o princípio

 

Se quiseres um auxílio mais efetivo vai ter que falar mais sobre o treco. Onde é usado, pra que serve, qual o ambiente, o que controla, o que tem ligado perto, o que 'louco' significa efetivamente, mostrar o layout, que tipo de sinal entra no sistema, de onde vem, se é cabo blindado, etc ou seja abrir o coração

Isto é óbvio d+ (pelo menos pra mim), mas se já descobriste que a fonte (chaveada?) é a origem do problema, que tal se tentasse colocar uma linear? ah .. já tentou e deu na mesma. ok.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 28/09/2016 às 13:48, Isadora Ferraz disse:

Suspeitei desde o princípio

 

Se quiseres um auxílio mais efetivo vai ter que falar mais sobre o treco. Onde é usado, pra que serve, qual o ambiente, o que controla, o que tem ligado perto, o que 'louco' significa efetivamente, mostrar o layout, que tipo de sinal entra no sistema, de onde vem, se é cabo blindado, etc ou seja abrir o coração

Isto é óbvio d+ (pelo menos pra mim), mas se já descobriste que a fonte (chaveada?) é a origem do problema, que tal se tentasse colocar uma linear? ah .. já tentou e deu na mesma. ok.

Vamos lá, primeiramente vou lhe mostra o layout inicial no eagle, que é este: https://www.dropbox.com/s/islht03igbp3pfh/placa.rar?dl=0

 

Alguma modificações foram feitas e vou descreve-las:

1º Um Jumper foi soldado no corpo do oscilador de 16MHZ, esse jumper foi colocado na parte negativa de um capacitor eletrolitico de 1uf e a parte positiva do capacitor foi colocado no 5v e um led foi colocado em paralelo com o capacitor.

o que mudou com isso? Antes disso quando você tocasse no cristal oscilador a placa parava na hora, todas suas saidas ligavam aleatóriamente e dificilmente o chip microcontrolador conseguia voltar ao seu funcionamento normal sem reseta-lo, após essa modificação foi eliminado totalmente esse defeito, o interessante é que algumas vezes que o cristal é tocado, o led pisca bem rápidamente conduzindo alguma eletricidade estática aplicada! lembrando que TODOS ESSES DEFEITOS que estão sendo apresentados acontecem apenas com a alimentação em fontes e nada disso acontece com baterias.

 

2º Um diodo foi colocado na entrada de VI da alimentação:

o que mudou? ***** nenhuma (só caiu 0,7v de VI pra não mentir)

 

3º O unico pino do microcontrolador que não foi ligado a nada, foi jampeado até o gnd.

 

4º As trilhas de GND foram estanhadas

 

5º Foi colocado um resistor de 1 M ohm em paralelo com o cristal oscilador

 

Fim das modificações feita _________________________

 

Uma coisa interessante falar é que, apesar da modificação 1 quando colocamos o dedo na parte de baixo (no circuito impresso) das conexões do cristal, o mesmo erro acontece (lembrando que quando alimentado por bateria isso não acontece), isso é facilmente resolvido aplicado fita isolando na parte de baixo das trilhas do cristal..

 

Fim das coisas interessantes a falar_________________________

 

Qual o problema atual e qual a função dela?

 

Esta placa esta instalado em um painel de um filtro manga,a função dela é ligar e desligar 15 saidas (uma por vez) para que possa ser feito um jateamento de ar e efetuado a limpeza deste filtro.

No painel tem instalado junto nada menos nada mais do que um inversor de frequência (não lembro qual) de um motor elétrico trifásico de 60cv e também vários e vários reles de 24v ( a fonte de alimentação de lá é 24v)

Após a placa ser ligada ela cumpre muito bem seu papel nos primeiros segundos, após algum tempo (varia muito esse tempo como de 5s a 30s) ela simplesmente para tudo ou liga umas saídas aleatória e trava e para voltar é necessário reseta-la)

E lembrando que após esta placa não ter funcionado muito bem e ainda não está funcionando neste ambiente, foi instalado a placa arduino uno r3 diretamente lá e ela se comporta muito bem, não fica "louca", engraçado que copiei os capacitores usados nessa placa e e resistor em paralelo com o cristal e não resolveu nada.

 

Alguém consegue salvar está placa que está me dando um trabalho do cão? haha

Editado por BRUNOGTS2011

Compartilhar este post


Link para o post
Compartilhar em outros sites

seu compartilhamento não foi muito feliz. Publique em jpg diretamente no forum. Também fotos de onde/como está instalado. Videos e o escambal podem  ajudar ainda+. Fale algo sobre a sugerida fonte linear externa que (não) colocou. Também sobre blindagens nos cabos/pci, também fale sobre aterramento (confiável) do sistema e tal. Fale também sobre o pino reset do seu precioso, se está "exposto" para gravação, tem capacitor e tal. Preciso saber também se ocorrem eventos que seu precioso não controla. tipo motor de 60cv ligando/desligando, relés, lampadas etc.

 

Seu coração ainda está 1/2 fechado.

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Isadora Ferraz disse:

seu compartilhamento não foi muito feliz. Publique em jpg diretamente no forum. Também fotos de onde/como está instalado. Videos e o escambal podem  ajudar ainda+. Fale algo sobre a sugerida fonte linear externa que (não) colocou. Também sobre blindagens nos cabos/pci, também fale sobre aterramento (confiável) do sistema e tal. Fale também sobre o pino reset do seu precioso, se está "exposto" para gravação, tem capacitor e tal. Preciso saber também se ocorrem eventos que seu precioso não controla. tipo motor de 60cv ligando/desligando, relés, lampadas etc.

 

Seu coração ainda está 1/2 fechado.

esq.pngesq2.png

 

Aqui esta o precioso! haha

Sei que você me fala de o ambiente que ele se encontra, sobre aterramento, cabos etc, mas o que tento entender mais é, porque quando colocada a placa Arduíno uno r3 diretamente lá não causa nenhum travamento? (com a mesma fonte) e quando coloco está sim? o que a placa Arduíno tem que está não tem? o que falta?

Editado por BRUNOGTS2011
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não conheço a arduíno mas não é o que falta.. é o que sobra! Na sua pci está sobrando trilhas! Estas agem com antena. Aliás ta parecendo uma placa de antena RFID. As conexões vcc e gnd não estão otimizadas, terra do cristal indo pro 7805 causa corrente parasita - certo é ir direto pro pino do mc -, posição dos capacitores de descoplamento devem ser melhoradas, não sei que tipo de entradas/saídas mas um capacitor em cada ajuda muito, e alguns, trilhas muito longas e alguns etc.

 

dica1:

Se a original funciona, tente copiá-la o mais fielmente possível. Ainda que penso que até ela mesma pode ser melhorada para ambientes rústicos.

dica2:

Tente envolvê-la (embrulhe mesmo) com algo isolante e em cima um papel alumínio com o mesmo aterrado no gnd que sai da fonte (e não na pci)

Deu certo?: blinde-a numa caixa metálica

 

Algumas décadas de experiências vão lhe fazer bem. Aguarde

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Como poderia melhorar o caminho das trilhas? o que seria otimizar as trilhas vcc e gnd? seriam deixar elas mais largas? e também não entendi muito bem sobre o terra indo por 7805, poderia me dar mais detalhes? posicionamento também dos capacitores gostaria que falasse mais também...

É tantas dúvidas kkkkkkkk... então podemos dizer que essa placa pode tacar fora e só serviu como experiencia? haha

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 horas atrás, BRUNOGTS2011 disse:

essa placa pode tacar fora e só serviu como experiencia

É uma opção que pode ser cogitada no entanto sugiro antes fazer o lance da blindagem que te falei.

 

Vou falar quase uma tese sobre o +5 (vulgo vcc): observe-o saindo do 7805 e indo pro pino vcc do mc. Deveria "morrer" aí. No entanto a partir deste pino você o distribui pra sei lá onde. O mc gosta de exclusividade na alimentação. Se o + 5 tem que ir pra outros setores, pegue a partir do pino de saida do 7805. Alguns preferem um +5 só pra ele (com outro 7805 pra "corja"). O mesmo pro gnd. Capacitores devem estar no trajeto dos vcc/gnd e mc e nunca depois dele. Perceba a posição do eletrolitico (47uf acho)

 

X2 e X3:se tivessem em cima as trilhas seriam menores

 

E percebo agora a principal falha grave: cade o capacitor 100nF no pino reset? Ah usa o pino como I/O. Tente outro e use-o como reset mesmo. E com capacitor

 

Alguns ambientes muito sujos mesmo deve-se até mesmo lançar mão de acoplador ótico pra evitar "contágio" do mundo externo no sensível mc

 

Você está a ler algumas décadas em poucos minutos

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Isadora Ferraz disse:

É uma opção que pode ser cogitada no entanto sugiro antes fazer o lance da blindagem que te falei.

 

Vou falar quase uma tese sobre o +5 (vulgo vcc): observe-o saindo do 7805 e indo pro pino vcc do mc. Deveria "morrer" aí. No entanto a partir deste pino você o distribui pra sei lá onde. O mc gosta de exclusividade na alimentação. Se o + 5 tem que ir pra outros setores, pegue a partir do pino de saida do 7805. Alguns preferem um +5 só pra ele (com outro 7805 pra "corja"). O mesmo pro gnd. Capacitores devem estar no trajeto dos vcc/gnd e mc e nunca depois dele. Perceba a posição do eletrolitico (47uf acho)

 

X2 e X3:se tivessem em cima as trilhas seriam menores

 

E percebo agora a principal falha grave: cade o capacitor 100nF no pino reset? Ah usa o pino como I/O. Tente outro e use-o como reset mesmo. E com capacitor

 

Alguns ambientes muito sujos mesmo deve-se até mesmo lançar mão de acoplador ótico pra evitar "contágio" do mundo externo no sensível mc

 

Você está a ler algumas décadas em poucos minutos

 

Vou começar com a falha mais grave, que na verdade eu esqueci de mencionar nas modificações feita, o pino de reset que está conectado com um resistor e push button, na verdade eu anulei o resistor (jampeei) e tirei o botão, não sei se assim ainda precisaria colocar um capacitor nele. (poderia me falar?)

Agora entendi muito bem sobre as alimentações própria pro mic, erro de iniciante, realmente!

Sobre o posicionamento dos capacitores, desculpe, mas ainda não consegui entender o que você quis dizer :/

Gostaria também de suas décadas de experiência e saber se trilhas "quadradonas" do jeito que eu faço está errado ou se há algum estilo que melhore o desempenho da placa em relação a ruídos, ahhh e também é interessante deixar as trilhas vcc/gnd sempre mais largas?

 

Agora vou contar uma coisa que fiquei de boca aberta na hora haha

ft.jpg

Repare nesta linda fonte, ela foi a ÚNICA que conseguiu deixar a placa funcionando como se nada estivesse acontecendo.

Esta placa tem a finalidade de ligar/desligar dois módulos relés de 8 canais cada (x2 e x3), os relés tem a função de ligar outros relés do painel, esta fonte é 12v e os relés secundários são 24v, ou seja, não da, para testes ligamos está fonte apenas na placa e relés primários (5V) e deixamos a fonte do painel (24V) ligado nos relés secundários e acredite, mesmo não estando eletricamente ligados, após ligar aquele fonte de 24v nos relés a placa começou a apresentar o mesmo erro, e sem ela não, como pode? O.O

 

Acredito que vou deixar esta placa apenas como aprendizado e refazer outra (bem mais pra frente em breve) com suas dicas e se apresentar o mesmo defeito eu a encapsulo pra ver o que acontece.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
11 horas atrás, BRUNOGTS2011 disse:

precisaria colocar um capacitor nele

sim precisa. Penso que deva ser 10K 100nF

 

11 horas atrás, BRUNOGTS2011 disse:

Sobre o posicionamento dos capacitores

algo como

vcc-------o------|
          |      |
          -      M
          -      C
          |      |
gnd-------o-------

e não

vcc-------o------|
          |      |
          M      -
          C      -
          |      |
gnd-------o------|

 

Realmente trilhas quadradas 90º não são muito interessantes eletricamente falando. Melhor é com 45º. Em circuitos de RF usam até redondas (com arco).

Sim vcc e gnd quanto mais largas melhor. Em circuitos RF ou dupla face deixam até planas - grande área de cobre. Se multicamadas, camadas planas exclusivas pra vcc/gnd

 

Não entendi direito o penúltimo parágrafo mas penso que sua placa aciona relé de 12 e este o de 24. E basta ligar a fonte de 24 pra zoar tudo. É isso? Neste caso deves lançar mão de algum filtro R ou L ou C ou os 3 juntos. Chuto um toróide qualquer em série com vcc/gnd um C de uns 10nF. Ou melhor vide filtro de linha. O pulo do gato é o indutor (as vezes o tal toroidal) quase = a um trafinho cuja disposição dos indutores - um "indo" outro "vindo"  tentam provocar a anulação de algum ruído

 

Se você for OBRIGADO  a usar a fonte do sistema, os desafios devem ser considerados.  Por outro lado, outro projeto, cogite usa fonte própria (uma 5v linearzinha ou até mesmo de carregador de celular) e conversar com o sistema via acoplador ótico. Isto pode reduzir a chance de aparecer os "fantasmas que assolam a alma do sistema" - vulgo ruídos que interferem no processamento do mc e dão vida própria ao firmware kk

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caraca, eu pra mim se os capacitores estivessem ligados na mesma trilha em paralelo pensava que não tinha diferença alguma por ser do mesmo "fio", esquecendo isso, é como se o ruído atingisse o mic e depois o capacitor tentasse resolver algo mas ai já é tarde demais?

Depois dessas décadas lidas já da pra mim aplicar um monte de alterações, espero que eu não precise de centenários para resolver este problema. haha

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×