Ir ao conteúdo
  • Cadastre-se
Diego Shimizu

Formatação condicional entre células de diferentes planilhas

Recommended Posts

Bom dia.

Tenho a seguinte situação: Um arquivo Excel com duas planilhas (Abas).

Na primeira tenho uma relação de NOMES; Na segunda, uma relação de TAREFAS.

Os nomes estão definidos para a cor de fonte preta. O que quero fazer é: Sempre que um dos nomes da planilha NOMES aparecer, em qualquer lugar da planilha TAREFAS, sua cor, na planilha NOMES será alterada para vermelho.

É possível?

 

Muito obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Certo, obrigado.

"Qualquer lugar" significa não apenas em uma célula específica, mas em qualquer celular que seja editada.

A dúvida porém continua: Como fazer esse vínculo? Tem ideia?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Restringir esse 'qq lugar' significa não pesquisar pela planilha inteira (mais de um milhão de linhas) ou sua planilha ficará lenta qq q seja a solução. Pense num intervalo como A1:Z1000.

você poderia usar algo como:

=SOMARPRODUTO(--(Planilha1!A1:Z1000="item_procurado"))

na formatação condicional.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Desculpe, mas sou meio leigo com isso. Onde deveria digitar a fórmula que enviou? Na planilha NOMES ou TAREFAS? Estou enviando anexo um arquivo como exemplo. Neste modelo, sempre que o nome for inserido na aba TAREFAS, deverá ficar vermelho na aba NOMES. Como faço isso?

EXEMPLO.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Desculpe, mas não consegui realizar a operação na tabela pretendida. Além disso, no exemplo que postou, ao digitar o nome FFF nas primeiras linhas da aba TAREFAS, ele não é marcado na aba NOMES.

Poderia, por gentileza, explicar as fórmulas?

 

=SOMARPRODUTO(--(TAREFAS!B2:B1001=$A4))

 

=SOMARPRODUTO(--(TAREFAS!B1:B1000=$A3))

 

Obrigado pela ajuda

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Diego Shimizu disse:

Desculpe, mas não consegui realizar a operação na tabela pretendida. Além disso, no exemplo que postou, ao digitar o nome FFF nas primeiras linhas da aba TAREFAS, ele não é marcado na aba NOMES.

Poderia, por gentileza, explicar as fórmulas?

=SOMARPRODUTO(--(TAREFAS!B2:B1001=$A4))

=SOMARPRODUTO(--(TAREFAS!B1:B1000=$A3))

Obrigado pela ajuda

Muito bem Diego, você acabou destacando um erro q não havia reparado, a fórmula correta é:

=SOMARPRODUTO(--(TAREFAS!$B$1:$B$1000=$A3))

 

O q a fórmula faz?

Ela compara todas as células q estão no intervalo entre TAREFAS!$B$1:$B$1000, agora fixo por conta do $, com valores na coluna A da guia NOMES, se ele encontrar retorna VERDADEIRO, caso contrário FALSO. FALSO e VERDADEIRO são transformados em 0 (zero) e 1 (um) p/ poderem ser somados na função SOMARPRODUTO() pelos dois sinais de menos --.

Para a Formatação Condicional qq valor positivo maior q zero é interpretado como VERDADEIRO e desta forma ela aplica a formatação desejada, do contrário (FALSO) não aplica.

você pode estender o intervalo como você quiser, mas a planilha irá perdendo desempenho a medida q o intervalo se torna muito extenso e as comparações com valores se multiplicam, por isso você deve ser comedido.

adicionado 2 minutos depois
2 horas atrás, klauscosta disse:

Bom dia!

 

Estou precisando de ajuda com a formula: =SOMASES('ACORDO JUSTIÇA'!$C$3:$C$1048576;'ACORDO JUSTIÇA'!$D$3:$D$1048576;"=01/01/16"), que ao copiar a formula para as demais células a data siga a sequencia. da forma apresentada a data permanece nas demais células.

 

É só mudar "=01/01/16" pelo endereço da referência q você quer, exemplo:

=SOMASES('ACORDO JUSTIÇA'!$C$3:$C$1048576;'ACORDO JUSTIÇA'!$D$3:$D$1048576;P5)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×