Ir ao conteúdo
  • Cadastre-se
Fzmorais

Agrupamento de dados via fórmula

Recommended Posts

Bom dia,

 

Preciso agrupar dados automaticamente no excel via formula e não macro\Dinâmica, a função deve varrer a coluna e em nova coluna inserir o dado sem estar repetido. Abaixo segue exemplo.

 

Coluna Original:

Sigla

A

A

A

A

A

A

C

C

C

C

C

C

B

B

B

B

B

B

 

Coluna Agrupada

 

Sigla

A

B

C

 

Obrigado

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Fzmorais seja bem vindo ao forum!

considerando que os dados esteja na coluna A cole a formula abaixo na linha B2, Aperte as teclas CTRL+SHIFT+ENTER (formula Matricial), e arraste ate a linha desejada.

 

 =SEERRO(ÍNDICE($A$2:$A$19;CORRESP(0;CONT.SE($B$1:B1;$A$2:$A$19);0));"") 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×