Ir ao conteúdo
  • Cadastre-se
Eduardo2345

Formula excel - comando se + copiar somente valores

Recommended Posts

Eduardo2345

 

Tenta assim confere

 

=SE(A1=V1;W1;"")

 

A formula faz o seguinte, se A1 = V1 então mostra valor de W1 se não for igual não mostra nada

 

Decio

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente algo assim: 

Udf  use (ex.): =Teste_Copiar_valores(A1;V1;W1)

Cole a função em um modulo padrão, E ssalve o arq. como habilitado macros... (*.xlsm)

 

Function Teste_Copiar_valores(rng As Range, rng2 As Range, rng3 As Range) As String
'Se A1=V1 copiar W1.
' Use (ex.): =Teste_Copiar_valores(A1;V1;W1)
    With ActiveSheet
    
    If rng.Value = rng2.Value Then
    Teste_Copiar_valores = rng3.Value
    End If
    
    End With

End Function

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×