Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
ET Bilu

Exercício de vetores visualg

Recommended Posts

"Crie um algoritmo que leia um vetor de 30 números inteiros e gere um segundo vetor cujas posições pares são o dobro do vetor original e as ímpares o triplo." 

 

Foi isso que fiz até agora, e o visualg apontou erro de sintaxe. Alguém ajuda.

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 15/10/2016
// Seção de Declarações
var
v,v2:vetor[1..30] de inteiro
i,tam:inteiro
inicio
tam<-30
para i de 1 ate tam faca
   leia(v[i])
fimpara
para i de 1 ate tam faca
   se (v[i] mod 2)=0 então
      v[i]*2<-v2[i]
   senao
      v[i]*3<-v2[i]
   fimse
fimpara
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ET Bilu    Seu Código Está Bom, Só Tem Um Pequeno Erro Ali No Se, No Caso A

Posição No Vetor É A Variável i, Então É Preciso Ver Se É Par Ou Ímpar, Experimente 
Colocar Assim:

   se i mod 2=0 então
     v2[i]:=v[i]*2
   senao
     v2[i]:=v[i]*3
   fimse

E Também Ali Na Hora Do Leia Seria Bom Colocar Uma Informação Para Que O 
Usuário Saiba O Que Fazer, Então Ali Antes Do Leia Coloque Isso:

escreval("Digite Um Número E Tecle Enter")

E No Final Pode-se Mostrar Os Valores Nos Vetores .

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ET Bilu   Se Você Colocar Do Jeito Que Eu Postei Acredito Que Vai Funcionar Certo

Pelo Menos Aqui Eu Testei E Está Funcionando.

  Veja Que As Variáveis Estão Ao Contrário, Entâo  É v2 na posição i que recebe v na

posição i multiplicado por 2 ou por 3.

   se i mod 2 = 0 então
      v2[i] := v[i]*2
   senao
      v2[i] := v[i]*3
   fimse

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×