Ir ao conteúdo
  • Cadastre-se
Priscila Lopes Svolinski

Procv + concatenar

Recommended Posts

Pessoal, boa tarde!

Alguém sabe como faço para montar uma formula de PROCV + CONCATENAR??

EX:

Preciso buscar na tabela uma informação e encontrando ela preciso concatenar essas informações de 4 colunas.

DIA: 01 ___________________CÓDIGO CONCATENADO: 011116XX011000

DIA \ DATA \ DESCRIÇÃO \ CODIGO \ VALOR
01 \ 011116 \ XXYYY \ XX-01 \ 10,00
02
03
04
.. etc

Se dia for 01 então vou quero criar meu PROCV para achando o respectivo dia ele concatene os campos que quero, mas está dando erro, o que fiz de errado?  
Segue abaixo o código que estou usando:

'=PROCV(D12;B15:E45;CONCATENAR(C15:C45;D15:D45;E15:E45);VERDADEIRO)

Já agradeço a atenção.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Segue planilha modelo em anexo.

TESTEPROCVCONCATENAR.xlsx

adicionado 2 minutos depois
21 minutos atrás, deciog disse:

@DJunqueira

 

Confere se é desta forma que deseja fiz dois modelos

Décio

 

 

Exemplo Decio (1).xlsx

 Obrigada Décio, seus exemplos enriqueceram meus conhecimentos, não conhecia até então essa funções, obrigada de coração.

 Agora quero apanhar mais um pouco para tentar achar uma solução para esse procv rs, consegue me ajudar nisso?

Compartilhar este post


Link para o post
Compartilhar em outros sites
38 minutos atrás, DJunqueira disse:

Veja se é isso q quer.

TESTEPROCVCONCATENAR.xlsx

Obrigada DJunqueira, era isso mesmo.

 

Valeu demais!

adicionado 2 minutos depois
2 minutos atrás, deciog disse:

@Priscila Lopes Svolinski

 

Apesar que o colega @DJunqueira  já solucionou o seu problema , fiz com INDICE e CORRESP para voce estudar a formula é quase igual a PROCV

 

Décio

 

TESTEPROCVCONCATENAR Decio.zip

Décio, showwww, adorei demais!!! estudando em 3,2,1!!! obrigada pela força, vou ficar expert nelas! bom final de semana! um abraço a todos!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×